Skip to content
Find file
Fetching contributors…
Cannot retrieve contributors at this time
86 lines (86 sloc) 3.64 KB
<?xml version="1.0" encoding="utf-8"?>
<Project ToolsVersion="4.0" DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
<PropertyGroup Condition="'$(Configuration)' == 'Documentation'">
<OutputPath>.\Source</OutputPath>
</PropertyGroup>
<PropertyGroup Condition="'$(Configuration)' == 'Debug'">
<OutputPath>.\Source</OutputPath>
</PropertyGroup>
<PropertyGroup Condition="'$(Configuration)' == 'Release'">
<OutputPath>.\Source</OutputPath>
</PropertyGroup>
<PropertyGroup Condition="'$(Configuration)' == 'Nsis'">
<OutputPath>.\Source</OutputPath>
<PlatformTarget>AnyCPU</PlatformTarget>
<CodeAnalysisIgnoreBuiltInRuleSets>false</CodeAnalysisIgnoreBuiltInRuleSets>
<CodeAnalysisIgnoreBuiltInRules>false</CodeAnalysisIgnoreBuiltInRules>
<CodeAnalysisFailOnMissingRules>false</CodeAnalysisFailOnMissingRules>
</PropertyGroup>
<PropertyGroup>
<OutputPath>.\Source</OutputPath>
<LatexPath>$(OutputPath)\latex</LatexPath>
<HtmlPath>$(OutputPath)\html</HtmlPath>
<ProjectGuid>{650C6F3D-33B5-4216-9536-956AB42C0624}</ProjectGuid>
<TargetFrameworkVersion>v4.0</TargetFrameworkVersion>
<Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
<Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
<ProductVersion>10.0.0</ProductVersion>
<SchemaVersion>2.0</SchemaVersion>
<OutputType>Exe</OutputType>
<AssemblyName>Build.Docs</AssemblyName>
<TargetFrameworkProfile />
</PropertyGroup>
<PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Documentation|AnyCPU' ">
<DebugType>none</DebugType>
<Optimize>False</Optimize>
<OutputPath>Source</OutputPath>
<WarningLevel>4</WarningLevel>
</PropertyGroup>
<PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
<DebugType>none</DebugType>
<Optimize>False</Optimize>
<OutputPath>Source</OutputPath>
<WarningLevel>4</WarningLevel>
</PropertyGroup>
<PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
<DebugType>none</DebugType>
<Optimize>False</Optimize>
<OutputPath>Source</OutputPath>
<WarningLevel>4</WarningLevel>
</PropertyGroup>
<PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Nsis|AnyCPU' ">
<DebugType>none</DebugType>
<Optimize>False</Optimize>
<OutputPath>Source</OutputPath>
<WarningLevel>4</WarningLevel>
</PropertyGroup>
<ItemGroup>
<None Include="app.config" />
<None Include="Doxyfile" />
</ItemGroup>
<ItemGroup>
<None Include="Changelog.txt" />
<None Include="Contributors.txt" />
<None Include="Instructions.txt" />
<None Include="License.txt" />
<None Include="Release.txt" />
<None Include="Todo.txt" />
</ItemGroup>
<Target Name="Build">
<Exec Command="doxygen" />
<Exec Command="pdflatex -interaction=batchmode refman.tex" WorkingDirectory="$(LatexPath)" />
<Exec Command="makeindex -q refman.idx" WorkingDirectory="$(LatexPath)" />
<Exec Command="pdflatex -interaction=batchmode refman.tex" WorkingDirectory="$(LatexPath)" />
<Copy SourceFiles="$(LatexPath)\refman.pdf" DestinationFiles="Reference.pdf" />
</Target>
<Target Name="Clean">
<Delete Files="Reference.pdf" />
<Delete Files="texput.log" />
<RemoveDir Directories="$(OutputPath)" Condition="'$(OS)' == 'Windows_NT'" />
<Exec Command="rm -rf $(OutputPath)" Condition="'$(OS)' != 'Windows_NT'" />
</Target>
<Target Name="Rebuild">
<CallTarget Targets="Clean" />
<CallTarget Targets="Build" />
</Target>
</Project>
Something went wrong with that request. Please try again.