Permalink
Browse files

chore: Remove support for angular below 1.4

Removes all tests and references to support
for angular versions below 1.4

BREAKING CHANGE:
UI Grid is no longer compatible with
angular versions below 1.4
1 parent 13a1117 commit 4341af5e47974e318a44951b72d93168bed445e2 @JLLeitschuh JLLeitschuh committed Feb 8, 2016
View
No changes.
View
@@ -22,7 +22,7 @@ http://localhost:9003/docs/#/tutorial to browse each tutorial.
<br/> fast - alias for --no-e2e --core --angular=1.3.6
```
-grunt dev --no-e2e --angular=1.3.16
+grunt dev --no-e2e --angular=1.5.0
```
# Code Structure
View
@@ -9,7 +9,7 @@ var util = require('./lib/grunt/utils.js');
/*global module:false*/
module.exports = function(grunt) {
require('time-grunt')(grunt);
-
+
// use load-grunt-config to load config settings for each individual task from grunt/
require('load-grunt-config')(grunt, {
// use jitGrunt to automatically load the grunt tasks that we have defined in our package.json
@@ -36,6 +36,8 @@ module.exports = function(grunt) {
pkg: grunt.file.readJSON('package.json'),
version: util.getVersion(),
stable_version: util.getStableVersion(),
+ latestAngular: util.latestAngular(),
+ angularTestVersions: util.angulars(),
dist: 'dist',
site: process.env.TRAVIS ? 'ui-grid.info' : '127.0.0.1:<%= connect.docs.options.port %>',
banner: '/*!\n' +
@@ -47,7 +49,7 @@ module.exports = function(grunt) {
}
});
-
+
util.updateConfig();
grunt.loadTasks('lib/grunt');
View
@@ -18,16 +18,16 @@ module.exports = {
},
scripts: [
// no jquery automatically loaded for tutorial!!!
- '//ajax.googleapis.com/ajax/libs/angularjs/1.4.3/angular.js',
- '//ajax.googleapis.com/ajax/libs/angularjs/1.4.3/angular-touch.js',
- '//ajax.googleapis.com/ajax/libs/angularjs/1.4.3/angular-animate.js',
+ '//ajax.googleapis.com/ajax/libs/angularjs/<%= latestAngular %>/angular.js',
+ '//ajax.googleapis.com/ajax/libs/angularjs/<%= latestAngular %>/angular-touch.js',
+ '//ajax.googleapis.com/ajax/libs/angularjs/<%= latestAngular %>/angular-animate.js',
'bower_components/csv-js/csv.js',
'bower_components/pdfmake/build/pdfmake.js',
'bower_components/pdfmake/build/vfs_fonts.js'
],
hiddenScripts: [
- '//ajax.googleapis.com/ajax/libs/angularjs/1.4.3/angular-animate.js',
- '//ajax.googleapis.com/ajax/libs/angularjs/1.4.3/angular-aria.js',
+ '//ajax.googleapis.com/ajax/libs/angularjs/<%= latestAngular %>/angular-animate.js',
+ '//ajax.googleapis.com/ajax/libs/angularjs/<%= latestAngular %>/angular-aria.js',
'bower_components/google-code-prettify/src/prettify.js',
'node_modules/marked/lib/marked.js'
],
@@ -316,7 +316,7 @@ module.exports = function(grunt) {
'main': releaseFiles,
'ignore': [],
'dependencies': {
- 'angular': '>=1.2.16 1.4.x'
+ 'angular': '>=1.4.0 1.5.x'
},
'repository': pkg.repository,
'homepage': 'http://ui-grid.info',
Oops, something went wrong.

0 comments on commit 4341af5

Please sign in to comment.