Permalink
Browse files

v1.0.0-beta.24

  • Loading branch information...
1 parent 3459300 commit db4e0242c482be46b47b78d54c9b4c33bbf57591 @hansl hansl committed Dec 20, 2016
View
@@ -1,6 +1,27 @@
+<a name="1.0.0-beta.24"></a>
+# [1.0.0-beta.24](https://github.com/angular/angular-cli/compare/v1.0.0-beta.23...v1.0.0-beta.24) (2016-12-20)
+
+
+### Bug Fixes
+
+* **@ngtools/webpack:** report errors during codegen ([#3608](https://github.com/angular/angular-cli/issues/3608)) ([0f604ac](https://github.com/angular/angular-cli/commit/0f604ac))
+* **build:** hashes in prod builds now changes when ID change. ([#3609](https://github.com/angular/angular-cli/issues/3609)) ([8e9abf9](https://github.com/angular/angular-cli/commit/8e9abf9))
+* **test:** exclude non spec files from test.ts ([#3538](https://github.com/angular/angular-cli/issues/3538)) ([bcb324f](https://github.com/angular/angular-cli/commit/bcb324f))
+* **tests:** serve `assets` files from `ng test` ([#3628](https://github.com/angular/angular-cli/issues/3628)) ([3459300](https://github.com/angular/angular-cli/commit/3459300))
+* **webpack:** correctly load component stylesheets ([#3511](https://github.com/angular/angular-cli/issues/3511)) ([d4da7bd](https://github.com/angular/angular-cli/commit/d4da7bd))
+
+
+### Features
+
+* **generate:** Show files updated when generating ([#3642](https://github.com/angular/angular-cli/issues/3642)) ([c011b04](https://github.com/angular/angular-cli/commit/c011b04)), closes [#3624](https://github.com/angular/angular-cli/issues/3624)
+* **version:** display versions of [@angular](https://github.com/angular)/* and [@ngtools](https://github.com/ngtools)/* ([#3592](https://github.com/angular/angular-cli/issues/3592)) ([123f74d](https://github.com/angular/angular-cli/commit/123f74d)), closes [#3589](https://github.com/angular/angular-cli/issues/3589)
+
+
+
<a name="1.0.0-beta.23"></a>
# [1.0.0-beta.23](https://github.com/angular/angular-cli/compare/v1.0.0-beta.22-1...v1.0.0-beta.23) (2016-12-15)
+This beta was abandoned and unpublished due to a breaking bug.
### Bug Fixes
View
@@ -1,6 +1,6 @@
{
"name": "angular-cli",
- "version": "1.0.0-beta.23",
+ "version": "1.0.0-beta.24",
"description": "CLI tool for Angular",
"main": "packages/angular-cli/lib/cli/index.js",
"trackingCode": "UA-8594346-19",
@@ -42,10 +42,10 @@
"homepage": "https://github.com/angular/angular-cli",
"dependencies": {
"@angular-cli/ast-tools": "^1.0.0",
- "@angular/compiler": "~2.3.1",
- "@angular/compiler-cli": "~2.3.1",
- "@angular/core": "~2.3.1",
- "@angular/tsc-wrapped": "~0.5.0",
+ "@angular/compiler": "^2.3.1",
+ "@angular/compiler-cli": "^2.3.1",
+ "@angular/core": "^2.3.1",
+ "@angular/tsc-wrapped": "^0.5.0",
"async": "^2.1.4",
"autoprefixer": "^6.5.3",
"chalk": "^1.1.3",
@@ -101,7 +101,7 @@
"resolve": "^1.1.7",
"rimraf": "^2.5.3",
"rsvp": "^3.0.17",
- "rxjs": "5.0.0-rc.4",
+ "rxjs": "^5.0.1",
"sass-loader": "^4.0.1",
"script-loader": "^0.7.0",
"semver": "^5.1.0",
@@ -124,7 +124,8 @@
"webpack-dev-server": "2.1.0-beta.9",
"webpack-merge": "^0.14.0",
"webpack-sources": "^0.1.3",
- "yam": "0.0.18"
+ "yam": "0.0.18",
+ "zone.js": "^0.7.2"
},
"ember-addon": {
"paths": [
@@ -1,6 +1,6 @@
{
"name": "@angular-cli/ast-tools",
- "version": "1.0.10",
+ "version": "1.0.11",
"description": "CLI tool for Angular",
"main": "./src/index.js",
"keywords": [
@@ -24,8 +24,8 @@
"npm": ">= 3.0.0"
},
"dependencies": {
- "@angular/tsc-wrapped": "^0.3.0",
- "rxjs": "5.0.0-rc.4",
+ "@angular/tsc-wrapped": "^0.5.0",
+ "rxjs": "^5.0.1",
"denodeify": "^1.2.1",
"typescript": "~2.0.3"
}
@@ -1,6 +1,6 @@
{
"name": "@angular-cli/base-href-webpack",
- "version": "1.0.9",
+ "version": "1.0.10",
"description": "Base HREF Webpack plugin",
"main": "./src/index.js",
"keywords": [
@@ -1,6 +1,6 @@
{
"name": "@ngtools/webpack",
- "version": "1.2.0",
+ "version": "1.2.1",
"description": "Webpack plugin that AoT compiles your Angular components and modules.",
"main": "./src/index.js",
"typings": "src/index.d.ts",
@@ -31,10 +31,10 @@
"source-map": "^0.5.6"
},
"peerDependencies": {
- "@angular/compiler": "~2.3.1",
- "@angular/compiler-cli": "~2.3.1",
- "@angular/core": "~2.3.1",
- "@angular/tsc-wrapped": "~0.5.0",
+ "@angular/compiler": "^2.3.1",
+ "@angular/compiler-cli": "^2.3.1",
+ "@angular/core": "^2.3.1",
+ "@angular/tsc-wrapped": "^0.5.0",
"typescript": "^2.0.2",
"reflect-metadata": "^0.1.8",
"webpack": "^2.1.0-beta.25"
@@ -133,8 +133,10 @@ export class AotPlugin implements Tapable {
}
this._rootFilePath = fileNames;
- // Check the genDir.
- let genDir = basePath;
+ // Check the genDir. We generate a default gendir that's under basepath; it will generate
+ // a `node_modules` directory and because of that we don't want TypeScript resolution to
+ // resolve to that directory but the real `node_modules`.
+ let genDir = path.join(basePath, '$$_gendir');
this._compilerOptions = tsConfig.options;
this._angularCompilerOptions = Object.assign(
@@ -13,21 +13,21 @@
},
"private": true,
"dependencies": {
- "@angular/common": "~2.3.1",
- "@angular/compiler": "~2.3.1",
- "@angular/core": "~2.3.1",
- "@angular/forms": "~2.3.1",
- "@angular/http": "~2.3.1",
- "@angular/platform-browser": "~2.3.1",
- "@angular/platform-browser-dynamic": "~2.3.1",
- "@angular/router": "~3.3.1",
+ "@angular/common": "^2.3.1",
+ "@angular/compiler": "^2.3.1",
+ "@angular/core": "^2.3.1",
+ "@angular/forms": "^2.3.1",
+ "@angular/http": "^2.3.1",
+ "@angular/platform-browser": "^2.3.1",
+ "@angular/platform-browser-dynamic": "^2.3.1",
+ "@angular/router": "^3.3.1",
"core-js": "^2.4.1",
- "rxjs": "5.0.0-rc.4",
+ "rxjs": "^5.0.1",
"ts-helpers": "^1.1.1",
"zone.js": "^0.7.2"
},
"devDependencies": {
- "@angular/compiler-cli": "~2.3.1",
+ "@angular/compiler-cli": "^2.3.1",
"@types/jasmine": "2.5.38",
"@types/node": "^6.0.42",
"angular-cli": "<%= version %>",
@@ -1,5 +1,10 @@
/*eslint-disable no-console */
+// Prevent the dependency validation from tripping because we don't import zone.js. We need
+// it as a peer dependency of @angular/core.
+// require('zone.js')
+
+
// This file hooks up on require calls to transpile TypeScript.
const cli = require('../../ember-cli/lib/cli');
const UI = require('../../ember-cli/lib/ui');
@@ -1,6 +1,6 @@
{
"name": "angular-cli",
- "version": "1.0.0-beta.23",
+ "version": "1.0.0-beta.24",
"description": "CLI tool for Angular",
"main": "lib/cli/index.js",
"trackingCode": "UA-8594346-19",
@@ -27,9 +27,9 @@
"dependencies": {
"@angular-cli/ast-tools": "^1.0.1",
"@angular-cli/base-href-webpack": "^1.0.0",
- "@angular/compiler": "~2.3.1",
- "@angular/compiler-cli": "~2.3.1",
- "@angular/core": "~2.3.1",
+ "@angular/compiler": "^2.3.1",
+ "@angular/compiler-cli": "^2.3.1",
+ "@angular/core": "^2.3.1",
"@ngtools/webpack": "^1.0.0",
"async": "^2.1.4",
"autoprefixer": "^6.5.3",
@@ -103,7 +103,8 @@
"webpack-dev-server": "2.1.0-beta.9",
"webpack-merge": "^0.14.0",
"webpack-sources": "^0.1.3",
- "yam": "0.0.18"
+ "yam": "0.0.18",
+ "zone.js": "^0.7.2"
},
"ember-addon": {
"paths": [
@@ -2,18 +2,18 @@
"name": "test",
"license": "MIT",
"dependencies": {
- "@angular/common": "~2.3.1",
- "@angular/compiler": "~2.3.1",
- "@angular/compiler-cli": "~2.3.1",
- "@angular/core": "~2.3.1",
- "@angular/http": "~2.3.1",
- "@angular/platform-browser": "~2.3.1",
- "@angular/platform-browser-dynamic": "~2.3.1",
- "@angular/platform-server": "~2.3.1",
- "@angular/router": "~3.3.1",
+ "@angular/common": "^2.3.1",
+ "@angular/compiler": "^2.3.1",
+ "@angular/compiler-cli": "^2.3.1",
+ "@angular/core": "^2.3.1",
+ "@angular/http": "^2.3.1",
+ "@angular/platform-browser": "^2.3.1",
+ "@angular/platform-browser-dynamic": "^2.3.1",
+ "@angular/platform-server": "^2.3.1",
+ "@angular/router": "^3.3.1",
"@ngtools/webpack": "0.0.0",
"core-js": "^2.4.1",
- "rxjs": "5.0.0-rc.4",
+ "rxjs": "^5.0.1",
"zone.js": "^0.7.2"
},
"devDependencies": {
@@ -2,18 +2,18 @@
"name": "test",
"license": "MIT",
"dependencies": {
- "@angular/common": "~2.3.1",
- "@angular/compiler": "~2.3.1",
- "@angular/compiler-cli": "~2.3.1",
- "@angular/core": "~2.3.1",
- "@angular/http": "~2.3.1",
- "@angular/platform-browser": "~2.3.1",
- "@angular/platform-browser-dynamic": "~2.3.1",
- "@angular/platform-server": "~2.3.1",
- "@angular/router": "~3.3.1",
+ "@angular/common": "^2.3.1",
+ "@angular/compiler": "^2.3.1",
+ "@angular/compiler-cli": "^2.3.1",
+ "@angular/core": "^2.3.1",
+ "@angular/http": "^2.3.1",
+ "@angular/platform-browser": "^2.3.1",
+ "@angular/platform-browser-dynamic": "^2.3.1",
+ "@angular/platform-server": "^2.3.1",
+ "@angular/router": "^3.3.1",
"@ngtools/webpack": "0.0.0",
"core-js": "^2.4.1",
- "rxjs": "5.0.0-rc.4",
+ "rxjs": "^5.0.1",
"zone.js": "^0.7.2"
},
"devDependencies": {

0 comments on commit db4e024

Please sign in to comment.