New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

@angular/compiler-cli Incompatible peer dependencies found #13126

Closed
enddering opened this Issue Dec 4, 2018 · 1 comment

Comments

Projects
None yet
2 participants
@enddering

enddering commented Dec 4, 2018

Bug Report or Feature Request (mark with an x)

- [x] bug report -> please search issues before submitting
- [ ] feature request

Command (mark with an x)

- [ ] new
- [ ] build
- [ ] serve
- [ ] test
- [ ] e2e
- [ ] generate
- [ ] add
- [x] update
- [ ] lint
- [ ] xi18n
- [ ] run
- [ ] config
- [ ] help
- [ ] version
- [ ] doc

Versions

7.1.1

Repro steps

The log given by the failure

ng update --all
Package "@angular/compiler-cli" has an incompatible peer dependency to "typescript" (requires ">=3.1.1 <3.2", would install "3.2.1").
Incompatible peer dependencies found. See above.

Desired functionality

compatible ts 3.2.1

Mention any other details that might be useful

@alan-agius4

This comment has been minimized.

Collaborator

alan-agius4 commented Dec 4, 2018

Duplicate of #13095

@alan-agius4 alan-agius4 marked this as a duplicate of #13095 Dec 4, 2018

@alan-agius4 alan-agius4 closed this Dec 4, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment