New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ng update not running migration.json schematic #13139

Closed
tanzeelrana opened this Issue Dec 5, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@tanzeelrana

tanzeelrana commented Dec 5, 2018

Bug Report or Feature Request (mark with an x)

- [x ] bug report -> please search issues before submitting
- [ ] feature request

Command (mark with an x)

- [ ] new
- [ ] build
- [ ] serve
- [ ] test
- [ ] e2e
- [ ] generate
- [ ] add
- [ x] update
- [ ] lint
- [ ] xi18n
- [ ] run
- [ ] config
- [ ] help
- [ ] version
- [ ] doc

Versions

node --version
v8.11.3

npm --version
6.4.1

ng --version

     _                      _                 ____ _     ___
    / \   _ __   __ _ _   _| | __ _ _ __     / ___| |   |_ _|
   / △ \ | '_ \ / _` | | | | |/ _` | '__|   | |   | |    | |
  / ___ \| | | | (_| | |_| | | (_| | |      | |___| |___ | |
 /_/   \_\_| |_|\__, |\__,_|_|\__,_|_|       \____|_____|___|
                |___/


Angular CLI: 6.1.1
Node: 8.11.3
OS: darwin x64
Angular: 6.1.10
... common, core, router

Package                             Version
-------------------------------------------------------------
@angular-devkit/architect           0.7.5
@angular-devkit/build-angular       0.7.5
@angular-devkit/build-optimizer     0.7.5
@angular-devkit/build-webpack       0.7.5
@angular-devkit/core                0.6.8
@angular-devkit/schematics          0.7.1
@angular/animations                 6.1.0
@angular/cdk                        6.4.7
@angular/cli                        6.1.1
@angular/compiler                   6.1.0
@angular/compiler-cli               6.1.0
@angular/forms                      6.1.0
@angular/http                       6.1.0
@angular/language-service           6.1.0
@angular/platform-browser           6.1.0
@angular/platform-browser-dynamic   6.1.0
@ngtools/webpack                    6.1.5
@schematics/angular                 0.7.1
@schematics/update                  0.7.1
rxjs                                6.3.3
typescript                          2.9.2
webpack                             4.9.2

Repro steps

I have a private project so I am unable to share the repo, so sorry in advance. I have an angular project to which I have added schematics support so I can update it using ng update. So I have a schematics folder with a migration.json file :

{
  "$schema": "../../../node_modules/@angular-devkit/schematics/collection-schema.json",
  "schematics": {
    "migration01": {
      "version": "1.0.0-nav-menu-with-migration.3",
      "description": "Update",
      "factory": "./src/ng-update/index"
    }
  }
}

tsconfig.schematics.json :

{
  "compilerOptions": {
    "target": "es2015",
    "module": "commonjs",
    "moduleResolution": "node",
    "declaration": true,
    "sourceMap": true,
    "lib": [
      "dom",
      "es2017",
      "esnext.asynciterable"
    ]
  },
  "exclude": [
    "**/files/*.ts",
    "**/*.spec.ts"
  ]
}

tsconfig.schematics.spec.json :

{
  "compilerOptions": {
    "module": "commonjs",
    "target": "es2015",
    "moduleResolution": "node",
    "types": [
      "jasmine",
      "node"
    ],
    "lib": [
        "es2017",
        "dom"
    ],
    "declaration": false
  },
  "include": [
    "./spec/**/*.spec.ts"
  ]
}

jasmine.json :

{
  "spec_dir": "projects/nav-menu/schematics/spec",
  "spec_files": [
    "**/*.spec.js"
  ],
  "helpers": [
    "projects/nav-menu/schematics/spec/helpers/**/*.js"
  ],
  "stopSpecOnExpectationFailure": false,
  "random": false
}

I have an ng-update folder with index.ts :

import { Rule, SchematicContext, SchematicsException, Tree } from "@angular-devkit/schematics";

export default function(): Rule {
  return (tree: Tree, context: SchematicContext) => {
    context.logger.warn("it's happening!");

    const pkgPath = "/package.json";
    const buffer = tree.read(pkgPath);
    if (buffer == null) {
      throw new SchematicsException("Could not read package.json");
    }
    const content = buffer.toString();
    const pkg = JSON.parse(content);

    if (pkg === null || typeof pkg !== "object" || Array.isArray(pkg)) {
      throw new SchematicsException("Error reading package.json");
    }

    if (!pkg.dependencies) {
      pkg.dependencies = {};
    }

    if (pkg.dependencies["@solarwinds/nav-menu-with-migration"]) {
      pkg.dependencies["ngx-perfect-scrollbar"] = `^7.0.0`;
      pkg.dependencies["ngx-device-detector"] = null;

      tree.overwrite(pkgPath, JSON.stringify(pkg, null, 2));
    }

    return tree;
  };
}

package.json for my nav menu project :

{
  "name": "@solarwinds/nav-menu-with-migration",
  "version": "0.0.1",
  "peerDependencies": {
    "css-element-queries": "~0.4.0",
    "ngx-perfect-scrollbar": "^7.0.0",
    "web-animations-js": "^2.3.1",
    "@angular/cdk": "^6.0.2",
    "@angular/common": "^6.0.7",
    "@angular/core": "^6.0.7",
    "@angular/router": "^6.0.7",
    "@solarwinds/nova-xui": "6.3.0-alpha.10.1322",
    "rxjs": "^6.0.0",
    "zone.js": "^0.8.26"
  },
  "schematics": "./schematics/collection.json",
  "ng-update": {
    "migrations": "./schematics/migration.json"
  }
}

Once I publish my package I try to update nav-menu in one of my other application's which use this package. I have tried a number of different commands and non of them seem to run the migration.json schematic on ng update. So I have tried :

ng update @solarwinds/nav-menu-with-migration --to=1.0.0-nav-menu-with-migration.3 --migrate-only

and I get the following error: Incompatible peer dependencies found. See above

Package "@solarwinds/nova-xui" has an incompatible peer dependency to "@angular/cdk" (requires "6.3.3", would install "6.4.7").
                 Package "@angular/http" has an incompatible peer dependency to "@angular/core" (requires "6.1.0" (extended), wouldinstall "6.1.10").
                 Package "@angular/platform-browser-dynamic" has an incompatible peer dependency to "@angular/common" (requires "6.1.0" (extended), would install "6.1.10").
                 Package "@angular/router" has an incompatible peer dependency to "@angular/platform-browser" (requires "6.1.10", would install "6.1.0")
                 Package "@solarwinds/nova-xui" has an incompatible peer dependency to "@angular/router" (requires "6.1.4" (extended), would install "6.1.10").
                 Package "@solarwinds/nova-xui" has an incompatible peer dependency to "rxjs" (requires "6.2.2", would install "6.3.3").
Incompatible peer dependencies found. See above.

So I tried with --force flag and I do get my package.json file updated but I never see my migration.json schematic run.

g update @solarwinds/nav-menu-with-migration --to=1.0.0-nav-menu-with-migration.3 --force --migrate-only

Package "@solarwinds/nova-xui" has an incompatible peer dependency to "rxjs" (requires "6.2.2", would install "6.3.3").
                  Package "@solarwinds/nova-xui" has an incompatible peer dependency to "@angular/cdk" (requires "6.3.3", would install "6.4.7").
                  Package "@angular/platform-browser-dynamic" has an incompatible peer dependency to "@angular/core" (requires "6.1.0" (extended), would install "6.1.10").
                  Package "@angular/router" has an incompatible peer dependency to "@angular/platform-browser" (requires "6.1.10", would install "6.1.0")
                  Package "@solarwinds/nova-xui" has an incompatible peer dependency to "@angular/router" (requires "6.1.4" (extended), would install "6.1.10").
                  Package "@angular/platform-browser-dynamic" has an incompatible peer dependency to "@angular/common" (requires "6.1.0" (extended), would install "6.1.10").
    Updating package.json with dependency rxjs @ "6.3.3" (was "6.2.2")...
    Updating package.json with dependency @angular/cdk @ "6.4.7" (was "6.4.3")...
    Updating package.json with dependency @angular/core @ "6.1.10" (was "6.1.0")...
    Updating package.json with dependency @angular/router @ "6.1.10" (was "6.1.0")...
    Updating package.json with dependency @angular/common @ "6.1.10" (was "6.1.0")...

I am not sure why my ng update command is not run. I wanted to test my migration.json schematic so I pointed my collection.json to point to ng-update/index so that when I run ng add @solarwinds/nav-menu-with-migration@1.0.0-nav-menu-with-migration.3 I can see if my ng-update code work and it does work as expected (Note: this was only to test purpose and I do not intend to use ng add to run migrations). Here is the output :

TREHMAN-MB:web-application-seed tanzeel.rehman$ ng add @solarwinds/nav-menu-with-migration@1.0.0-nav-menu-with-migration.3Installing packages for tooling via npm.
npm WARN @solarwinds/nav-menu@2.2.0 requires a peer of @solarwinds/nova-xui@6.3.0-alpha.10.1322 but none is installed. You must install peer dependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/animations@6.1.4 but none is installed. You must install peer dependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/cdk@6.3.3 but none is installed. You must install peerdependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/common@6.1.4 but none is installed. You must install peer dependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/compiler@6.1.4 but none is installed. You must installpeer dependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/core@6.1.4 but none is installed. You must install peer dependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/forms@6.1.4 but none is installed. You must install peer dependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/http@6.1.4 but none is installed. You must install peer dependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/platform-browser@6.1.4 but none is installed. You mustinstall peer dependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/platform-browser-dynamic@6.1.4 but none is installed. You must install peer dependencies yourself.
npm WARN @solarwinds/nova-xui@6.3.0-alpha.12.1825 requires a peer of @angular/router@6.1.4 but none is installed. You must install peer dependencies yourself.
npm WARN tsickle@0.30.0 requires a peer of typescript@>=2.4.2 <2.9 but none is installed. You must install peer dependencies yourself.
npm WARN @solarwinds/nav-menu-with-migration@1.0.0-nav-menu-with-migration.3 requires a peer of ngx-perfect-scrollbar@^7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @solarwinds/nav-menu-with-migration@1.0.0-nav-menu-with-migration.3 requires a peer of @solarwinds/nova-xui@6.3.0-alpha.10.1322 but none is installed. You must install peer dependencies yourself.

+ @solarwinds/nav-menu-with-migration@1.0.0-nav-menu-with-migration.3
updated 1 package and audited 40530 packages in 16.964s
found 10 vulnerabilities (3 low, 5 moderate, 2 high)
  run `npm audit fix` to fix them, or `npm audit` for details
Installed packages for tooling via npm.
    it's happening!
UPDATE package.json (4250 bytes)

Can someone help me with ng update here. Please, Thank you in advance!!

@alan-agius4

This comment has been minimized.

Collaborator

alan-agius4 commented Dec 9, 2018

Hello, we reviewed this issue and determined that it doesn't fall into the bug report or feature request category. This issue tracker is not suitable for support requests, please repost your issue on StackOverflow using tag angular-cli.

If you are wondering why we don't resolve support issues via the issue tracker, please check out this explanation.

@alan-agius4 alan-agius4 closed this Dec 9, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment