Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

No matching version found for @angular-devkit/core@8.3.18 #16109

Closed
acim opened this issue Nov 7, 2019 · 2 comments

Comments

@acim
Copy link

@acim acim commented Nov 7, 2019

馃悶 Bug report

Is this a regression?

Yes, the previous version in which this bug was not present was: 8.3.17

Description

A clear and concise description of the problem...

npm install -g @angular/cli gives the following error:

npm ERR! code ETARGET
npm ERR! notarget No matching version found for @angular-devkit/core@8.3.18.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! notarget 
npm ERR! notarget It was specified as a dependency of '@angular/cli'
npm ERR! notarget
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2019-11-07T21_33_36_072Z-debug.log

npm install -g @angular/cli@8.3.17

works fine.

馃敩 Minimal Reproduction

npm install -g @angular/cli@8.3.18

馃敟 Exception or Error




npm ERR! code ETARGET
npm ERR! notarget No matching version found for @angular-devkit/core@8.3.18.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! notarget 
npm ERR! notarget It was specified as a dependency of '@angular/cli'
npm ERR! notarget
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2019-11-07T21_33_36_072Z-debug.log

馃實 Your Environment




Docker image node:12-alpine

Anything else relevant?

@clydin

This comment has been minimized.

Copy link
Member

@clydin clydin commented Nov 7, 2019

As per the npm registry, the version 8.3.18 is published and available as the latest tag: https://www.npmjs.com/package/@angular-devkit/core/v/8.3.18

As this has recently been published, the registry may take some time to propagate packages through its system. If using a proxy, this also may not yet have synchronized with the registry.

@clydin clydin closed this Nov 7, 2019
@acim

This comment has been minimized.

Copy link
Author

@acim acim commented Nov 7, 2019

Yes, it works now, thank you. I am backend guy, this just broke my build pipeline so I reacted 馃槃

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can鈥檛 perform that action at this time.