Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Bug] - TypeError: Cannot read property 'apply' of undefined #6075

Closed
johnpapa opened this issue Apr 25, 2017 · 9 comments

Comments

@johnpapa
Copy link
Contributor

commented Apr 25, 2017

OS

Mac OSX Sierra 10.12.4

Versions

@angular/cli: 1.0.1
node: 6.9.1
os: darwin x64
@angular/common: 4.0.3
@angular/compiler: 4.0.3
@angular/core: 4.0.3
@angular/forms: 4.0.3
@angular/http: 4.0.3
@angular/platform-browser: 4.0.3
@angular/platform-browser-dynamic: 4.0.3
@angular/router: 4.0.3
@angular/cli: 1.0.1
@angular/compiler-cli: 4.0.3

Repro steps.

npm i -g @angular/cli
ng new foo
ng s -o

The app renders, but check the developer tools console and you will see ...

image

I am using Chrome

@hccampos

This comment has been minimized.

Copy link

commented Apr 25, 2017

It seems to be a zone.js problem. Using 0.8.7 instead of 0.8.8 works.

Duplicate of #6036 and #6047

@johnpapa

This comment has been minimized.

Copy link
Contributor Author

commented Apr 25, 2017

Just tested by pinning to zones 0.8.7 and it works.

@intellix

This comment has been minimized.

Copy link
Contributor

commented Apr 25, 2017

Supposedly fixed in: angular/zone.js#747

@iainplimmer

This comment has been minimized.

Copy link

commented Apr 25, 2017

Hi @johnpapa this is a dupe of #6036

@johnpapa

This comment has been minimized.

Copy link
Contributor Author

commented Apr 25, 2017

yep. i see that above

@intellix

This comment has been minimized.

Copy link
Contributor

commented Apr 25, 2017

@sumitarora

This comment has been minimized.

Copy link
Contributor

commented Apr 25, 2017

@johnpapa Working as expected no errors. 😄

@johnpapa

This comment has been minimized.

Copy link
Contributor Author

commented Apr 26, 2017

confirmed fixed with zones 0.8.9.

thanks!

@johnpapa johnpapa closed this Apr 26, 2017
@angular-automatic-lock-bot

This comment has been minimized.

Copy link

commented Sep 7, 2019

This issue has been automatically locked due to inactivity.
Please file a new issue if you are encountering a similar or related problem.

Read more about our automatic conversation locking policy.

This action has been performed automatically by a bot.

@angular-automatic-lock-bot angular-automatic-lock-bot bot locked and limited conversation to collaborators Sep 7, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
5 participants
You can’t perform that action at this time.