Skip to content
Permalink
Browse files

feat(compiler-cli): require node 8 as runtime engine (#22669)

This is not expected to be a breaking change for anyone who's on Node LTS (currently v8)
and aligns @angular/compilar-cli with @angular/cli's runtime requirements.

PR Close #22669
  • Loading branch information...
IgorMinar authored and kara committed Mar 10, 2018
1 parent 8449eb8 commit c602563589a7e14f0c57ee5b191979039aa370db
@@ -18,6 +18,9 @@
"typescript": ">=2.7.2 <2.8",
"@angular/compiler": "0.0.0-PLACEHOLDER"
},
"engines" : {
"node" : ">=8.0"
},
"repository": {
"type": "git",
"url": "https://github.com/angular/angular.git"
@@ -4,7 +4,10 @@
"compilerOptions": {
"module": "commonjs",
"stripInternal": false,
"target": "es5",
"target": "es2015",
"lib": [
"es2015"
],
"baseUrl": ".",
"rootDir": ".",
"paths": {
@@ -0,0 +1,9 @@
{
"extends": "./tsconfig.json",

This comment has been minimized.

Copy link
@obenbrahim

obenbrahim Mar 12, 2018

Contributor

"extends": "./tsconfig.json" seems to be causing circularity issue. I am filling an issue + PR for this

"compilerOptions": {
"target": "es2015",
"lib": [
"es2015"
]
}
}

0 comments on commit c602563

Please sign in to comment.
You can’t perform that action at this time.