New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Null InjectorError: No provider for e! #28063

Closed
sameer05k21a0440 opened this Issue Jan 11, 2019 · 2 comments

Comments

Projects
None yet
3 participants
@sameer05k21a0440
Copy link

sameer05k21a0440 commented Jan 11, 2019

  • Hi, after updated my package.json file I'm getting error like.

NullInjectorError: No provider for e!

"dependencies": {
   "@angular/animations": "^6.1.0",
   "@angular/cdk": "^6.1.0",
   "@angular/common": "^6.1.0",
   "@angular/compiler": "^6.1.0",
   "@angular/core": "^6.1.0",
   "@angular/forms": "^6.1.0",
   "@angular/http": "^6.1.0",
   "@angular/platform-browser": "^6.1.0",
   "@angular/platform-browser-dynamic": "^6.1.0",
   "@angular/router": "^6.1.0",
   "@ngx-translate/core": "^11.0.1",
   "@ngx-translate/http-loader": "^4.0.0",
   "bootstrap": "^4.1.3",
   "core-js": "^2.6.1",
   "echarts": "^4.2.0-rc.2",
   "jquery": "^3.3.1",
   "less": "^3.9.0",
   "marquee-infinite": "0.0.4",
   "mdbootstrap": "^4.6.0",
   "ng-zorro-antd": "^1.8.1",
   "polyfills": "^2.1.1",
   "rxjs": "~6.2.0",
   "rxjs-compat": "^6.2.1",
   "ts-xlsx": "0.0.11",
   "webpack-sources": "^1.3.0",
   "zone.js": "~0.8.26"
 },
 "devDependencies": {
   "@angular-devkit/build-angular": "^0.8.8",
   "@angular/cli": "6.1.0",
   "@angular/compiler-cli": "^6.1.0",
   "@angular/language-service": "^6.1.0",
   "@types/jasmine": "^2.8.14",
   "@types/jasminewd2": "~2.0.3",
   "@types/node": "~8.9.4",
   "codelyzer": "~4.3.0",
   "har-validator": "^5.1.3",
   "jasmine-core": "~2.99.1",
   "jasmine-spec-reporter": "~4.2.1",
   "karma": "~3.0.0",
   "karma-chrome-launcher": "~2.2.0",
   "karma-coverage-istanbul-reporter": "~2.0.1",
   "karma-jasmine": "~1.1.2",
   "karma-jasmine-html-reporter": "^0.2.2",
   "protractor": "~5.4.0",
   "ts-node": "~7.0.0",
   "tslint": "~5.11.0",
   "typescript": "~2.7.2"
 }
@alexzuza

This comment has been minimized.

Copy link
Contributor

alexzuza commented Jan 11, 2019

I believe you know it but
PLEASE create a minimal GitHub repository with the reproduction of the issue and add the link to your question.

@pkozlowski-opensource

This comment has been minimized.

Copy link
Member

pkozlowski-opensource commented Jan 11, 2019

Thanks for reporting this issue. However, you didn't provide sufficient information for us to understand and reproduce the problem. Please check out our submission guidelines to understand why we can't act on issues that are lacking important information.

If the problem still exists in your application, please open a new issue and follow the instructions in the issue template.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment