New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm install complains about peer deps #5746

Closed
rolandjitsu opened this Issue Dec 9, 2015 · 13 comments

Comments

Projects
None yet
@rolandjitsu

rolandjitsu commented Dec 9, 2015

I get the following warnings when I install the latest alpha version:

npm WARN EPEERINVALID angular2@2.0.0-alpha.50 requires a peer of es6-promise@^3.0.2 but none was installed.
npm WARN EPEERINVALID angular2@2.0.0-alpha.50 requires a peer of es6-shim@^0.33.3 but none was installed.
npm WARN EPEERINVALID angular2@2.0.0-alpha.50 requires a peer of reflect-metadata@0.1.2 but none was installed.
npm WARN EPEERINVALID angular2@2.0.0-alpha.50 requires a peer of rxjs@5.0.0-alpha.14 but none was installed.
npm WARN EPEERINVALID angular2@2.0.0-alpha.50 requires a peer of zone.js@0.5.8 but none was installed.
@meenie

This comment has been minimized.

Show comment
Hide comment
@meenie

meenie Dec 9, 2015

Contributor

If you are using npm3, then you have to install all of those separately.
npm install es6-promise@^3.0.2 es6-shim@^0.33.3 reflect-metadata@0.1.2 rxjs@5.0.0-alpha.14 zone.js@0.5.8. This is temporary until things can be fixed properly.

Contributor

meenie commented Dec 9, 2015

If you are using npm3, then you have to install all of those separately.
npm install es6-promise@^3.0.2 es6-shim@^0.33.3 reflect-metadata@0.1.2 rxjs@5.0.0-alpha.14 zone.js@0.5.8. This is temporary until things can be fixed properly.

@rolandjitsu

This comment has been minimized.

Show comment
Hide comment
@rolandjitsu

rolandjitsu Dec 9, 2015

I am using the latest version of node and npm. That is how I fixed it, but just wanted to report it if it hasn't been reported yet.

rolandjitsu commented Dec 9, 2015

I am using the latest version of node and npm. That is how I fixed it, but just wanted to report it if it hasn't been reported yet.

@pkozlowski-opensource

This comment has been minimized.

Show comment
Hide comment
@pkozlowski-opensource

pkozlowski-opensource Dec 9, 2015

Member

It is a breaking change, see: 80b025a

It didn't make it to the changelog, unfortunately...

Member

pkozlowski-opensource commented Dec 9, 2015

It is a breaking change, see: 80b025a

It didn't make it to the changelog, unfortunately...

@rolandjitsu

This comment has been minimized.

Show comment
Hide comment
@rolandjitsu

rolandjitsu Dec 9, 2015

@pkozlowski-opensource that is great that those are required as separate deps, too bad it did not make it to the changelog.

Off topic, are there any other things that did not make it to the changelog that I should be aware of?

rolandjitsu commented Dec 9, 2015

@pkozlowski-opensource that is great that those are required as separate deps, too bad it did not make it to the changelog.

Off topic, are there any other things that did not make it to the changelog that I should be aware of?

pkozlowski-opensource added a commit to pkozlowski-opensource/angular that referenced this issue Dec 9, 2015

@pkozlowski-opensource

This comment has been minimized.

Show comment
Hide comment
@pkozlowski-opensource

pkozlowski-opensource Dec 10, 2015

Member

that is great that those are required as separate deps, too bad it did not make it to the changelog.

Changelog was updated via 4e16fea

Member

pkozlowski-opensource commented Dec 10, 2015

that is great that those are required as separate deps, too bad it did not make it to the changelog.

Changelog was updated via 4e16fea

@osmanmeer

This comment has been minimized.

Show comment
Hide comment
@osmanmeer

osmanmeer Feb 23, 2016

I updated npm using 'npm install npm -g' but still getting the same error as OP. My current npm ver is 3.7.3.

osmanmeer commented Feb 23, 2016

I updated npm using 'npm install npm -g' but still getting the same error as OP. My current npm ver is 3.7.3.

@ReedRichard

This comment has been minimized.

Show comment
Hide comment
@ReedRichard

ReedRichard Mar 18, 2016

I am also seeing this issue with npm 3.8.2 on OS X.

ReedRichard commented Mar 18, 2016

I am also seeing this issue with npm 3.8.2 on OS X.

@ayyash

This comment has been minimized.

Show comment
Hide comment
@ayyash

ayyash Apr 11, 2016

I get

npm WARN angular2@2.0.0-beta.14 requires a peer of reflect-metadata@0.1.2 but none was installed.
npm WARN angular2@2.0.0-beta.14 requires a peer of rxjs@5.0.0-beta.2 but none was installed.

using npm 1.3.6, when trying to install latest of rxjs and reflect-metadata, does this mean I have to install the older versions?

ayyash commented Apr 11, 2016

I get

npm WARN angular2@2.0.0-beta.14 requires a peer of reflect-metadata@0.1.2 but none was installed.
npm WARN angular2@2.0.0-beta.14 requires a peer of rxjs@5.0.0-beta.2 but none was installed.

using npm 1.3.6, when trying to install latest of rxjs and reflect-metadata, does this mean I have to install the older versions?

@LindsayBrown81

This comment has been minimized.

Show comment
Hide comment
@LindsayBrown81

LindsayBrown81 Apr 25, 2016

I am using node v5.10.1 (npm v3.8.3) and I get
npm WARN angular2@2.0.0-beta.15 requires a peer of reflect-metadata@0.1.2 but none was installed. I am able to serve my app on local server despite the above message.

LindsayBrown81 commented Apr 25, 2016

I am using node v5.10.1 (npm v3.8.3) and I get
npm WARN angular2@2.0.0-beta.15 requires a peer of reflect-metadata@0.1.2 but none was installed. I am able to serve my app on local server despite the above message.

@matthewharwood

This comment has been minimized.

Show comment
Hide comment
@matthewharwood

matthewharwood Apr 28, 2016

+1 @LindsayBrown81 ├── UNMET PEER DEPENDENCY reflect-metadata@0.1.2

matthewharwood commented Apr 28, 2016

+1 @LindsayBrown81 ├── UNMET PEER DEPENDENCY reflect-metadata@0.1.2

@sateffen

This comment has been minimized.

Show comment
Hide comment
@sateffen

sateffen Apr 28, 2016

Just a little grind to the left: Why are this peer dependencies, if they are absolutely needed for angular? Why not regular dependencies? If it's well documented (and I expect angular to be well documented), then there is no problem? Or am I missing something?

I'm fighting with the version thing sometimes as well, especially when npm-check-update updates all dependencies, but angular depends on older versions and needs explicit versions.

sateffen commented Apr 28, 2016

Just a little grind to the left: Why are this peer dependencies, if they are absolutely needed for angular? Why not regular dependencies? If it's well documented (and I expect angular to be well documented), then there is no problem? Or am I missing something?

I'm fighting with the version thing sometimes as well, especially when npm-check-update updates all dependencies, but angular depends on older versions and needs explicit versions.

@paynoattn

This comment has been minimized.

Show comment
Hide comment
@paynoattn

paynoattn May 11, 2016

even with the correct peer dependencies installed npm still warns as of 2.0.0-beta.17

paynoattn commented May 11, 2016

even with the correct peer dependencies installed npm still warns as of 2.0.0-beta.17

@chaitugk01

This comment has been minimized.

Show comment
Hide comment
@chaitugk01

chaitugk01 Jul 6, 2017

Go a head and install

npm install es6-promise
npm install -g rx

like wise

chaitugk01 commented Jul 6, 2017

Go a head and install

npm install es6-promise
npm install -g rx

like wise

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment