Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ci: update nodejs version to v10.16.0 #31088

Closed

Conversation

@devversion
Copy link
Member

commented Jun 17, 2019

  • See individual commits for more details.

@googlebot googlebot added the cla: yes label Jun 17, 2019

@devversion devversion force-pushed the devversion:ci/update-nodejs-version-10.16.0 branch 8 times, most recently from 525ee94 to c759228 Jun 17, 2019

ci: update nodejs version to v10.16.0
Updates the NodeJS version to the latest stable version at the time of
writing (v10.16.0). We need to update our image to use a minimum NodeJS
version of v10.15.0 because new CLI apps automatically install a non-locked
version of selenium-webdriver that now requires NodeJS >= 10.15.0 since the
latest release of 17th June 2019 (4.0.0-alpha.3).

See CI failures: https://circleci.com/gh/angular/angular/359077

@devversion devversion force-pushed the devversion:ci/update-nodejs-version-10.16.0 branch from c759228 to b199df1 Jun 17, 2019

fix(bazel): builder workspace should use nodejs v10.16.0
The generated Bazel workspace by the `@angular/bazel` builder should
use the latest stable NodeJS version. This is necessary because some
packages like `selenium-webdriver` which are part of the default bazel
setup in order to support `ng e2e` depend on a minimum NodeJS version
of `10.15.0`.. This means that running e2e tests in a plain new bazel CLI
project (`ng new {projectName} --collection=@angular/bazel`) errors.

```
command.
 (error selenium-webdriver@4.0.0-alpha.3: The engine "node" is incompatible with
 this module. Expected version ">= 10.15.0". Got "10.13.0"
error Found incompatible module
)
```

@devversion devversion force-pushed the devversion:ci/update-nodejs-version-10.16.0 branch from 1a249b3 to 767eb16 Jun 17, 2019

@devversion devversion marked this pull request as ready for review Jun 17, 2019

@devversion devversion requested review from angular/docs-infra as code owners Jun 17, 2019

@ngbot ngbot bot added this to the needsTriage milestone Jun 17, 2019

@alexeagle

This comment has been minimized.

Copy link
Contributor

commented Jun 17, 2019

Can we fix the missing pinning on selenium-webdriver?

@@ -8,7 +8,7 @@
"license": "MIT",
"engines": {
"node": ">=10.9.0 <11.0.0",

This comment has been minimized.

Copy link
@alexeagle

alexeagle Jun 17, 2019

Contributor

should the minimum node be advanced here? or we don't care since Bazel will download its own?

This comment has been minimized.

Copy link
@devversion

devversion Jun 17, 2019

Author Member

I don't think we care too much about it. We only bumped it at some point to ensure that caching works or that network errors are reported properly.

@alexeagle
Copy link
Contributor

left a comment

super-fishy that our CI breaks when someone else releases... there's a bug somewhere in our pinning

@devversion

This comment has been minimized.

Copy link
Member Author

commented Jun 17, 2019

@alexeagle Yeah I was surprised as well. Unfortunately we can't lock this easily because the integration test depends on ng new which generates a package.json file that is not locking dependencies. Meaning that protractor brings in the most recent minor version of selenium-webdriver.

@josephperrott

This comment has been minimized.

Copy link
Contributor

commented Jun 17, 2019

@devversion Can we open an issue in angular/angular-cli to track it? Its probably not good to be unpinned on their end either

@devversion

This comment has been minimized.

Copy link
Member Author

commented Jun 17, 2019

@josephperrott I'll check if we already have one or create one if that's not the case.

AndrewKushnir added a commit that referenced this pull request Jun 17, 2019

ci: update nodejs version to v10.16.0 (#31088)
Updates the NodeJS version to the latest stable version at the time of
writing (v10.16.0). We need to update our image to use a minimum NodeJS
version of v10.15.0 because new CLI apps automatically install a non-locked
version of selenium-webdriver that now requires NodeJS >= 10.15.0 since the
latest release of 17th June 2019 (4.0.0-alpha.3).

See CI failures: https://circleci.com/gh/angular/angular/359077

PR Close #31088

AndrewKushnir added a commit that referenced this pull request Jun 17, 2019

fix(bazel): builder workspace should use nodejs v10.16.0 (#31088)
The generated Bazel workspace by the `@angular/bazel` builder should
use the latest stable NodeJS version. This is necessary because some
packages like `selenium-webdriver` which are part of the default bazel
setup in order to support `ng e2e` depend on a minimum NodeJS version
of `10.15.0`.. This means that running e2e tests in a plain new bazel CLI
project (`ng new {projectName} --collection=@angular/bazel`) errors.

```
command.
 (error selenium-webdriver@4.0.0-alpha.3: The engine "node" is incompatible with
 this module. Expected version ">= 10.15.0". Got "10.13.0"
error Found incompatible module
)
```

PR Close #31088

gregmagolan pushed a commit to gregmagolan/angular that referenced this pull request Jun 17, 2019

fix(bazel): builder workspace should use nodejs v10.16.0 (angular#31088)
The generated Bazel workspace by the `@angular/bazel` builder should
use the latest stable NodeJS version. This is necessary because some
packages like `selenium-webdriver` which are part of the default bazel
setup in order to support `ng e2e` depend on a minimum NodeJS version
of `10.15.0`.. This means that running e2e tests in a plain new bazel CLI
project (`ng new {projectName} --collection=@angular/bazel`) errors.

```
command.
 (error selenium-webdriver@4.0.0-alpha.3: The engine "node" is incompatible with
 this module. Expected version ">= 10.15.0". Got "10.13.0"
error Found incompatible module
)
```

PR Close angular#31088
@@ -8,7 +8,7 @@
"license": "MIT",
"engines": {
"node": ">=10.9.0 <11.0.0",
"yarn": ">=1.12.1 <=1.14.0"
"yarn": ">=1.12.1 <=1.16.0"

This comment has been minimized.

Copy link
@gkalpak

gkalpak Jun 17, 2019

Member

Why this change?
Aren't we still using 1.13.0 on CI?
  If so, is it just to make it easier for people to use the latest locally?
    If so, shouldn't the same change be made in aio/package.json?

(So many questions... 😛)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.