New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Angular/cli 1.5 errors when installing Angular Material #8246

Closed
Danieliverant opened this Issue Nov 6, 2017 · 5 comments

Comments

Projects
None yet
5 participants
@Danieliverant

Danieliverant commented Nov 6, 2017

Bug, feature request, or proposal:

Bug.

What is the expected behavior?

Install Angular Material

What is the current behavior?

Not installing Angular Material.

What are the steps to reproduce?

  • Installed NPM.
  • Installed @angular/cli
  • npm install --save @angular/material @angular/animations

Which versions of Angular, Material, OS, TypeScript, browsers are affected?

_                      _                 ____ _     ___

/ \ _ __ __ _ _ | | __ _ _ __ / | | | |
/ △ \ | '
\ / _ | | | | |/ _ | '
| | | | | | |
/ ___ | | | | (
| | || | | (| | | | || |___ | |
/
/ __| |
|_
, |_,||_,|| _||_|
|___/

Angular CLI: 1.5.0
Node: 8.9.0
OS: win32 x64
Angular: 5.0.0
... animations, common, compiler, compiler-cli, core, forms
... http, language-service, platform-browser
... platform-browser-dynamic, router

@angular/cli: 1.5.0
@angular/material: 2.0.0-beta.12
@angular-devkit/build-optimizer: 0.0.32
@angular-devkit/core: 0.0.20
@angular-devkit/schematics: 0.0.35
@ngtools/json-schema: 1.1.0
@ngtools/webpack: 1.8.0
@schematics/angular: 0.1.0
typescript: 2.4.2
webpack: 3.8.1

Is there anything else we should know?

CLI Log:

npm WARN codelyzer@3.2.2 requires a peer of @angular/compiler@^2.3.1 || >=4.0.0-beta <5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN codelyzer@3.2.2 requires a peer of @angular/core@^2.3.1 || >=4.0.0-beta <5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.12 requires a peer of @angular/cdk@2.0.0-beta.12 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.12 requires a peer of @angular/core@~4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.12 requires a peer of @angular/common@~4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.2 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

@skonx

This comment has been minimized.

Show comment
Hide comment
@skonx

skonx Nov 6, 2017

Same on MacOS :

Angular CLI: 1.5.0
Node: 6.10.3
OS: darwin x64
Angular: 5.0.0
... animations, common, compiler, compiler-cli, core, forms
... http, platform-browser, platform-browser-dynamic
... platform-server, router

@angular/cdk: 2.0.0-beta.12
@angular/cli: 1.5.0
@angular/language-service: 4.4.6
@angular/material: 2.0.0-beta.12
@angular-devkit/build-optimizer: 0.0.32
@angular-devkit/core: 0.0.20
@angular-devkit/schematics: 0.0.35
@ngtools/json-schema: 1.1.0
@ngtools/webpack: 1.8.0
@schematics/angular: 0.1.0
typescript: 2.4.2
webpack: 3.8.1

npm install @angular/material @angular/cdk
npm WARN codelyzer@3.0.1 requires a peer of @angular/compiler@^2.3.1 || >=4.0.0-beta <5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN codelyzer@3.0.1 requires a peer of @angular/core@^2.3.1 || >=4.0.0-beta <5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.12 requires a peer of @angular/core@~4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.12 requires a peer of @angular/common@~4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/cdk@2.0.0-beta.12 requires a peer of @angular/core@~4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/cdk@2.0.0-beta.12 requires a peer of @angular/common@~4.4.4 but none is installed. You must install peer dependencies yourself.

skonx commented Nov 6, 2017

Same on MacOS :

Angular CLI: 1.5.0
Node: 6.10.3
OS: darwin x64
Angular: 5.0.0
... animations, common, compiler, compiler-cli, core, forms
... http, platform-browser, platform-browser-dynamic
... platform-server, router

@angular/cdk: 2.0.0-beta.12
@angular/cli: 1.5.0
@angular/language-service: 4.4.6
@angular/material: 2.0.0-beta.12
@angular-devkit/build-optimizer: 0.0.32
@angular-devkit/core: 0.0.20
@angular-devkit/schematics: 0.0.35
@ngtools/json-schema: 1.1.0
@ngtools/webpack: 1.8.0
@schematics/angular: 0.1.0
typescript: 2.4.2
webpack: 3.8.1

npm install @angular/material @angular/cdk
npm WARN codelyzer@3.0.1 requires a peer of @angular/compiler@^2.3.1 || >=4.0.0-beta <5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN codelyzer@3.0.1 requires a peer of @angular/core@^2.3.1 || >=4.0.0-beta <5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.12 requires a peer of @angular/core@~4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/material@2.0.0-beta.12 requires a peer of @angular/common@~4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/cdk@2.0.0-beta.12 requires a peer of @angular/core@~4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/cdk@2.0.0-beta.12 requires a peer of @angular/common@~4.4.4 but none is installed. You must install peer dependencies yourself.

@skonx

This comment has been minimized.

Show comment
Hide comment
@skonx

skonx Nov 6, 2017

it seems to work updating codelyzer to the latest version (4.0.1) and using angular/material2-builds angular/cdk-builds... we should wait to update to ng 5 using material 👍

skonx commented Nov 6, 2017

it seems to work updating codelyzer to the latest version (4.0.1) and using angular/material2-builds angular/cdk-builds... we should wait to update to ng 5 using material 👍

@josepfdc

This comment has been minimized.

Show comment
Hide comment
@josepfdc

josepfdc Nov 6, 2017

please, please !! upgrade as soon as possible material design for angular 5 ( angular cli 1.5)
thank you !!

josepfdc commented Nov 6, 2017

please, please !! upgrade as soon as possible material design for angular 5 ( angular cli 1.5)
thank you !!

@tgambet

This comment has been minimized.

Show comment
Hide comment
@tgambet

tgambet Nov 6, 2017

Duplicate of #7780. It should be adressed with today's release.

tgambet commented Nov 6, 2017

Duplicate of #7780. It should be adressed with today's release.

@josephperrott

This comment has been minimized.

Show comment
Hide comment
@josephperrott

josephperrott Nov 6, 2017

Contributor

Closing as duplicate of #7780

Contributor

josephperrott commented Nov 6, 2017

Closing as duplicate of #7780

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment