'Add layer' does not work with OpenLayers layer #32

Closed
jieter opened this Issue Nov 21, 2012 · 1 comment

Projects

None yet

2 participants

@jieter
jieter commented Nov 21, 2012

When I press 'add layer' in the settings dialog with Google Physical from the OpenLayers plugin, I get an error, detailed below.

If I remove that layer from my project, I can select a layer in TimeManager.

An error has occured while executing Python code:

Traceback (most recent call last):
  File "/home/jieter/.qgis//python/plugins/timemanager/timemanagerguicontrol.py", line 252, in showAddLayerDialog
    self.getLayerAttributes(0)
  File "/home/jieter/.qgis//python/plugins/timemanager/timemanagerguicontrol.py", line 277, in getLayerAttributes
    provider=layer.dataProvider()
AttributeError: 'OpenlayersLayer' object has no attribute 'dataProvider'

Python version:
2.7.1+ (r271:86832, Sep 27 2012, 21:22:46) 
[GCC 4.5.2]


QGIS version:
1.8.0-Lisboa Lisboa, exported

Python path: ['/usr/share/qgis/python', '/home/jieter/.qgis//python', '/home/jieter/.qgis//python/plugins', '/usr/share/qgis/python/plugins', '/usr/local/lib/python2.7/dist-packages/distribute-0.6.30-py2.7.egg', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-linux2', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/local/lib/python2.7/dist-packages/setuptools-0.6c11-py2.7.egg-info', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PIL', '/usr/lib/pymodules/python2.7/gtk-2.0', '/usr/lib/python2.7/dist-packages/gst-0.10', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/pymodules/python2.7', '/usr/lib/pymodules/python2.7/ubuntuone-storage-protocol', '/usr/lib/pymodules/python2.7/ubuntuone-client', '/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode', '/usr/share/qgis/python/plugins/fTools/tools', '~/.qgis/python', '.', '.', '.', '.', '.', '.', '.']
@anitagraser anitagraser added a commit that referenced this issue Dec 1, 2012
@anitagraser fix for #32, up to 0.7 05fa38a
@anitagraser
Owner

Thanks Jieter! Should be fixed in 0.7

@anitagraser anitagraser closed this Dec 1, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment