Browse files

Fix for namespaced requires

  • Loading branch information...
1 parent 98e63f9 commit fd484adb1f778dd1b6eb2648b59caf09be52e584 @yury yury committed Aug 21, 2012
Showing with 17 additions and 14 deletions.
  1. +1 −1 Rakefile
  2. +3 −0 lib/bootstrap-rails/engine.rb
  3. +13 −13 vendor/assets/javascripts/twitter/bootstrap.js
View
2 Rakefile
@@ -45,7 +45,7 @@ namespace :twitter do
js["popover.js"] = 3
list = js.to_a.sort {|a,b| a[1] <=> b[1]}.map{|p| p[0]}
- File.write "vendor/assets/javascripts/twitter/bootstrap.js", list.map {|f| "//= require #{f}"}.join("\n")
+ File.write "vendor/assets/javascripts/twitter/bootstrap.js", list.map {|f| "//= require twitter/bootstrap/#{f}"}.join("\n")
end
desc "Update Twitter's Bootstrap SCSS"
View
3 lib/bootstrap-rails/engine.rb
@@ -1,6 +1,9 @@
module Bootstrap
module Rails
class Engine < ::Rails::Engine
+ initializer 'anjlab-bootstrap-rails.setup' do |app|
+ config.sass.load_paths << File.join(config.root, 'vendor', 'frameworks')
+ end
end
end
end
View
26 vendor/assets/javascripts/twitter/bootstrap.js
@@ -1,13 +1,13 @@
-//= require transition.js
-//= require dropdown.js
-//= require button.js
-//= require carousel.js
-//= require collapse.js
-//= require alert.js
-//= require affix.js
-//= require typeahead.js
-//= require scrollspy.js
-//= require tab.js
-//= require modal.js
-//= require tooltip.js
-//= require popover.js
+//= require twitter/bootstrap/transition.js
+//= require twitter/bootstrap/dropdown.js
+//= require twitter/bootstrap/button.js
+//= require twitter/bootstrap/carousel.js
+//= require twitter/bootstrap/collapse.js
+//= require twitter/bootstrap/alert.js
+//= require twitter/bootstrap/affix.js
+//= require twitter/bootstrap/typeahead.js
+//= require twitter/bootstrap/scrollspy.js
+//= require twitter/bootstrap/tab.js
+//= require twitter/bootstrap/modal.js
+//= require twitter/bootstrap/tooltip.js
+//= require twitter/bootstrap/popover.js

0 comments on commit fd484ad

Please sign in to comment.