Permalink
Browse files

all files

  • Loading branch information...
1 parent 041db2c commit e546c548a877f0f04cdee73ad75eaa064503fb3d anoop.k.sinha@gmail.com committed Sep 6, 2011
Showing 964 changed files with 84,453 additions and 0 deletions.
View
1,839 CHANGELOG

Large diffs are not rendered by default.

Oops, something went wrong.
View
@@ -0,0 +1,50 @@
+The following people have contributed code, patches, bug fixes, and language
+translations to the Fat Free CRM:
+
+ * Alexander Kabanov (USA)
+ * Andrew Neil (United Kingdom)
+ * Apirak Panatkool (Thailand)
+ * Avery Pennarun (Canada)
+ * Beatriz Garcia Parrilla (Spain)
+ * Ben Tillman (Hong Kong)
+ * Cédric Brancourt (France)
+ * Craig Ulliott (USA)
+ * Dirk Kelly (Australia)
+ * Dmitry Dudin (Russia)
+ * Douglas Campos (Brasil)
+ * Dr. Nic Williams (Australia)
+ * Elad Meidar (Israel)
+ * Enderson Maia (Brasil)
+ * Eric Davis (USA)
+ * Eric Shelley (USA)
+ * Fritz Thielemann (Germany)
+ * Gavin Baker (USA)
+ * Hamish Rickerby (United Kingdom)
+ * Jack Tang (China)
+ * James Zhang (China)
+ * Jim Gay (USA)
+ * Jose Luis Gordo Romero (Spain)
+ * Kamil Politowicz (Germany)
+ * Lana Dvorkin (USA)
+ * Leonid Dinershtein (Russia)
+ * Louis Nyffenegger (Australia)
+ * Lukasz Kosewski (Canada)
+ * Matt Beedle (Spain)
+ * Martin Gajdos (Switzerland)
+ * Martin Trejo (Mexico)
+ * Miles Togoe (USA)
+ * Nathan Broadbent (Hong Kong)
+ * Nicholas Rowe (USA)
+ * Nobuhito Okada (Japan)
+ * Peter McCurdy (Canada)
+ * Ralf Ebert (Germany)
+ * Rit Li (USA)
+ * Roman Smirnov (Russia)
+ * Russell Niller (USA)
+ * Ryan Stenhouse (Scotland)
+ * Scott Miller (USA)
+ * Steve Kenworthy (Hong Kong)
+ * Todd Makinster (USA)
+ * Tom Meier (Australia)
+ * Trevor Oke (Canada)
+ * Yury Kotlyarov (Russia)
View
62 Gemfile
@@ -0,0 +1,62 @@
+source 'http://rubygems.org'
+
+gem 'rails', '3.0.7'
+gem 'rake', '0.8.7'
+
+# Loads the database adapter gem based on config/database.yml (Default: mysql2)
+# -----------------------------------------------------------------------------
+db_gems = {
+ "mysql2" => [ "mysql2", "0.2.7" ], # The latest 0.3.2 doesn't ship with ActiveRecord adapter as it's now part of Rails 3.1.
+ "mysql" => [ "mysql" ], # With Rails 3.0.x we're supposed to use mysql2 0.2.x release.
+ "postgresql" => [ "pg", ">= 0.9.0" ],
+ "sqlite3" => [ "sqlite3" ]
+}
+adapter = if File.exists?(db_config = File.join(File.dirname(__FILE__),"config","database.yml"))
+ # Fetch any configured adapters from config/database.yml
+ db = YAML.load_file(db_config); (db["development"] || db["test"] || db["production"])["adapter"]
+else
+ "mysql2"
+end
+if db_gems[adapter]
+ gem *db_gems[adapter]
+else
+ raise "Sorry, the db adapter in database.yml is unknown. Please add it to 'db_gems' in your Gemfile."
+end
+# -----------------------------------------------------------------------------
+
+gem 'acts_as_commentable', '>= 3.0.1'
+gem 'haml', '>= 3.1.1'
+gem 'sass', '>= 3.1.1'
+gem 'paperclip', '>= 2.3.3'
+gem 'will_paginate', '>= 3.0.pre2'
+
+group :development, :test do
+ gem 'ruby-debug', :platform => :mri_18
+ gem 'ruby-debug19', :platform => :mri_19, :require => 'ruby-debug'
+ gem 'annotate', '>= 2.4.0'
+ gem 'awesome_print', '>= 0.3.1'
+
+ gem 'test-unit', '1.2.3' if RUBY_VERSION.to_f >= 1.9
+ gem "rspec-rails", '>= 2.5.0'
+ gem 'ffaker', '>= 1.5.0'
+ gem 'faker', '0.3.1', :require => false
+ gem 'factory_girl', '>= 1.3.3'
+end
+
+
+# Gem watch list:
+#---------------------------------------------------------------------
+# gem 'authlogic', :git => 'git://github.com/crossroads/authlogic.git', :branch => 'rails3'
+# gem 'gravatar-ultimate', :git => 'git://github.com/crossroads/gravatar.git'
+# gem 'paperclip', :git => 'http://github.com/thoughtbot/paperclip.git'
+
+# Rails3 plugins that we use and their source repositories:
+#---------------------------------------------------------------------
+# gravatar_image_tag, git://github.com/mdeering/gravatar_image_tag.git
+# calendar_date_select, git://github.com/timcharper/calendar_date_select.git
+# country_select, git://github.com/rails/country_select.git
+# dynamic_form, git://github.com/rails/dynamic_form.git
+# is_paranoid, git://github.com/theshortcut/is_paranoid.git
+# prototype_legacy_helper, git://github.com/rails/prototype_legacy_helper.git
+# responds_to_parent, git://github.com/markcatley/responds_to_parent.git
+
View
@@ -0,0 +1,139 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ abstract (1.0.0)
+ actionmailer (3.0.7)
+ actionpack (= 3.0.7)
+ mail (~> 2.2.15)
+ actionpack (3.0.7)
+ activemodel (= 3.0.7)
+ activesupport (= 3.0.7)
+ builder (~> 2.1.2)
+ erubis (~> 2.6.6)
+ i18n (~> 0.5.0)
+ rack (~> 1.2.1)
+ rack-mount (~> 0.6.14)
+ rack-test (~> 0.5.7)
+ tzinfo (~> 0.3.23)
+ activemodel (3.0.7)
+ activesupport (= 3.0.7)
+ builder (~> 2.1.2)
+ i18n (~> 0.5.0)
+ activerecord (3.0.7)
+ activemodel (= 3.0.7)
+ activesupport (= 3.0.7)
+ arel (~> 2.0.2)
+ tzinfo (~> 0.3.23)
+ activeresource (3.0.7)
+ activemodel (= 3.0.7)
+ activesupport (= 3.0.7)
+ activesupport (3.0.7)
+ acts_as_commentable (3.0.1)
+ annotate (2.4.0)
+ archive-tar-minitar (0.5.2)
+ arel (2.0.10)
+ awesome_print (0.4.0)
+ builder (2.1.2)
+ cocaine (0.2.0)
+ columnize (0.3.4)
+ diff-lcs (1.1.3)
+ erubis (2.6.6)
+ abstract (>= 1.0.0)
+ factory_girl (2.1.0)
+ faker (0.3.1)
+ ffaker (1.8.1)
+ haml (3.1.2)
+ i18n (0.5.0)
+ linecache (0.46)
+ rbx-require-relative (> 0.0.4)
+ linecache19 (0.5.12)
+ ruby_core_source (>= 0.1.4)
+ mail (2.2.19)
+ activesupport (>= 2.3.6)
+ i18n (>= 0.4.0)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ mime-types (1.16)
+ mysql2 (0.2.7)
+ paperclip (2.4.0)
+ activerecord (>= 2.3.0)
+ activesupport (>= 2.3.2)
+ cocaine (>= 0.0.2)
+ mime-types
+ polyglot (0.3.2)
+ rack (1.2.3)
+ rack-mount (0.6.14)
+ rack (>= 1.0.0)
+ rack-test (0.5.7)
+ rack (>= 1.0)
+ rails (3.0.7)
+ actionmailer (= 3.0.7)
+ actionpack (= 3.0.7)
+ activerecord (= 3.0.7)
+ activeresource (= 3.0.7)
+ activesupport (= 3.0.7)
+ bundler (~> 1.0)
+ railties (= 3.0.7)
+ railties (3.0.7)
+ actionpack (= 3.0.7)
+ activesupport (= 3.0.7)
+ rake (>= 0.8.7)
+ thor (~> 0.14.4)
+ rake (0.8.7)
+ rbx-require-relative (0.0.5)
+ rspec (2.6.0)
+ rspec-core (~> 2.6.0)
+ rspec-expectations (~> 2.6.0)
+ rspec-mocks (~> 2.6.0)
+ rspec-core (2.6.4)
+ rspec-expectations (2.6.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.6.0)
+ rspec-rails (2.6.1)
+ actionpack (~> 3.0)
+ activesupport (~> 3.0)
+ railties (~> 3.0)
+ rspec (~> 2.6.0)
+ ruby-debug (0.10.4)
+ columnize (>= 0.1)
+ ruby-debug-base (~> 0.10.4.0)
+ ruby-debug-base (0.10.4)
+ linecache (>= 0.3)
+ ruby-debug-base19 (0.11.25)
+ columnize (>= 0.3.1)
+ linecache19 (>= 0.5.11)
+ ruby_core_source (>= 0.1.4)
+ ruby-debug19 (0.11.6)
+ columnize (>= 0.3.1)
+ linecache19 (>= 0.5.11)
+ ruby-debug-base19 (>= 0.11.19)
+ ruby_core_source (0.1.5)
+ archive-tar-minitar (>= 0.5.2)
+ sass (3.1.7)
+ thor (0.14.6)
+ treetop (1.4.10)
+ polyglot
+ polyglot (>= 0.3.1)
+ tzinfo (0.3.29)
+ will_paginate (3.0.0)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ acts_as_commentable (>= 3.0.1)
+ annotate (>= 2.4.0)
+ awesome_print (>= 0.3.1)
+ factory_girl (>= 1.3.3)
+ faker (= 0.3.1)
+ ffaker (>= 1.5.0)
+ haml (>= 3.1.1)
+ mysql2 (= 0.2.7)
+ paperclip (>= 2.3.3)
+ rails (= 3.0.7)
+ rake (= 0.8.7)
+ rspec-rails (>= 2.5.0)
+ ruby-debug
+ ruby-debug19
+ sass (>= 3.1.1)
+ will_paginate (>= 3.0.pre2)
View
@@ -0,0 +1,61 @@
+source 'http://rubygems.org'
+
+gem 'rails', '3.0.7'
+gem 'rake', '0.8.7'
+
+# Loads the database adapter gem based on config/database.yml (Default: mysql2)
+# -----------------------------------------------------------------------------
+db_gems = {
+ "mysql2" => [ "mysql2", "0.2.7" ], # The latest 0.3.2 doesn't ship with ActiveRecord adapter as it's now part of Rails 3.1.
+ "mysql" => [ "mysql" ], # With Rails 3.0.x we're supposed to use mysql2 0.2.x release.
+ "postgresql" => [ "pg", ">= 0.9.0" ],
+ "sqlite3" => [ "sqlite3" ]
+}
+adapter = if File.exists?(db_config = File.join(File.dirname(__FILE__),"config","database.yml"))
+ # Fetch any configured adapters from config/database.yml
+ db = YAML.load_file(db_config); (db["development"] || db["test"] || db["production"])["adapter"]
+else
+ "mysql2"
+end
+if db_gems[adapter]
+ gem *db_gems[adapter]
+else
+ raise "Sorry, the db adapter in database.yml is unknown. Please add it to 'db_gems' in your Gemfile."
+end
+# -----------------------------------------------------------------------------
+
+gem 'acts_as_commentable', '>= 3.0.1'
+gem 'haml', '>= 3.1.1'
+gem 'sass', '>= 3.1.1'
+gem 'paperclip', '>= 2.3.3'
+gem 'will_paginate', '>= 3.0.pre2'
+
+group :development, :test do
+ gem 'ruby-debug', :platform => :mri_18
+ gem 'ruby-debug19', :platform => :mri_19, :require => 'ruby-debug'
+ gem 'annotate', '>= 2.4.0'
+ gem 'awesome_print', '>= 0.3.1'
+
+ gem 'test-unit', '1.2.3' if RUBY_VERSION.to_f >= 1.9
+ gem "rspec-rails", '>= 2.5.0'
+ gem 'ffaker', '>= 1.5.0'
+ gem 'factory_girl', '>= 1.3.3'
+end
+
+
+# Gem watch list:
+#---------------------------------------------------------------------
+# gem 'authlogic', :git => 'git://github.com/crossroads/authlogic.git', :branch => 'rails3'
+# gem 'gravatar-ultimate', :git => 'git://github.com/crossroads/gravatar.git'
+# gem 'paperclip', :git => 'http://github.com/thoughtbot/paperclip.git'
+
+# Rails3 plugins that we use and their source repositories:
+#---------------------------------------------------------------------
+# gravatar_image_tag, git://github.com/mdeering/gravatar_image_tag.git
+# calendar_date_select, git://github.com/timcharper/calendar_date_select.git
+# country_select, git://github.com/rails/country_select.git
+# dynamic_form, git://github.com/rails/dynamic_form.git
+# is_paranoid, git://github.com/theshortcut/is_paranoid.git
+# prototype_legacy_helper, git://github.com/rails/prototype_legacy_helper.git
+# responds_to_parent, git://github.com/markcatley/responds_to_parent.git
+
Oops, something went wrong.

0 comments on commit e546c54

Please sign in to comment.