Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

moved over some code to install.rb instead of init.rb -- doesn't bloc…

…k generators
  • Loading branch information...
commit 9847dc7a1048e41112ab813f62f48fe37e6f37c3 1 parent 41c2901
Pradeep Elankumaran authored
Showing with 14 additions and 13 deletions.
  1. +0 −12 init.rb
  2. +14 −1 install.rb
View
12 init.rb
@@ -1,12 +0,0 @@
-RAILS_ENV ||= ENV["RAILS_ENV"]
-env_settings = YAML.load(File.open(File.join(RAILS_ROOT, "config", "bebo.yml")))[RAILS_ENV]
-ENV["BEBO_CALLBACK_PATH"] = env_settings["callback_path"]
-
-require 'bebo_connection'
-require 'bebo_controller_extensions'
-require 'bebo_view_extensions'
-require 'bebo_routing_extensions'
-require 'bebo_api'
-
-ActionController::Base.send(:include, BeboControllerExtensions)
-ActionView::Helpers::AssetTagHelper.send(:include, BeboViewExtensions::AssetTagHelper)
View
15 install.rb
@@ -1 +1,14 @@
-# Install hook code here
+# Install hook code here
+RAILS_ENV ||= ENV["RAILS_ENV"]
+file = File.join(RAILS_ROOT, "config", "bebo.yml")
+env_settings = YAML.load(File.open(file))[RAILS_ENV]
+ENV["BEBO_CALLBACK_PATH"] = env_settings["callback_path"]
+
+require 'bebo_connection'
+require 'bebo_controller_extensions'
+require 'bebo_view_extensions'
+require 'bebo_routing_extensions'
+require 'bebo_api'
+
+ActionController::Base.send(:include, BeboControllerExtensions)
+ActionView::Helpers::AssetTagHelper.send(:include, BeboViewExtensions::AssetTagHelper)
Please sign in to comment.
Something went wrong with that request. Please try again.