Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add Opsview Host module #31570

Open
wants to merge 13 commits into
base: devel
from

Conversation

@jpgxs
Copy link

commented Oct 11, 2017

Add Opsview Host module

SUMMARY

Adds common utilities for Opsview modules.
Adds module for adding, updating and deleting hosts in Opsview.

ISSUE TYPE
  • New Module Pull Request
COMPONENT NAME
  • opsview_host
ANSIBLE VERSION
ansible 2.5.0
  config file = None
  configured module search path = [u'/usr/share/ansible/plugins/modules']
  ansible python module location = /virtualenvs/ansible/local/lib/python2.7/site-packages/ansible-2.5.0-py2.7.egg/ansible
  executable location = /virtualenvs/ansible/bin/ansible
  python version = 2.7.6 (default, Oct 26 2016, 20:30:19) [GCC 4.8.4]
@ansibot

This comment has been minimized.

Copy link
Contributor

commented Oct 11, 2017

The test ansible-test sanity --test validate-modules [?] failed with the following errors:

lib/ansible/modules/monitoring/opsview_host.py:0:0: E307 version_added should be 2.5. Currently 2.4
lib/ansible/modules/monitoring/opsview_host.py:0:0: E312 No RETURN provided

click here for bot help

@jpgxs jpgxs force-pushed the opsview:devel branch Oct 11, 2017

@ansibot ansibot removed the ci_verified label Oct 11, 2017

@ansibot

This comment has been minimized.

Copy link
Contributor

commented Oct 11, 2017

@D3DeFi @NickatEpic @abulimov @andsens @aps-sids @bhcopeland @bpennypacker @brian-brazil @bwhaley @cave @ccollicutt @cove @dmsimard @dstoflet @eikef @ethanculler @harrisongu @hkariti @ivanvanderbyl @kavu @mcodd @n0ts @nate-kingsley @nerzhul @Sedward @skornehl @smbambling @stympy @suprememoocow @tbielawa @woz5999

As a maintainer of a module in the same namespace this new module has been submitted to, your vote counts for shipits. Please review this module and add shipit if you would like to see it merged.

click here for bot help

@jpgxs jpgxs force-pushed the opsview:devel branch from 9be609a to a087663 Mar 6, 2019

@ansibot

This comment has been minimized.

Copy link
Contributor

commented Mar 6, 2019

@jpgxs this PR contains more than one new module.

Please submit only one new module per pull request. For a detailed explanation, please read the grouped modules documentation

click here for bot help

@ansibot

This comment has been minimized.

Copy link
Contributor

commented Mar 6, 2019

The test ansible-test sanity --test ansible-doc --python 3.8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:0:0: has a documentation error formatting or is missing documentation.

The test ansible-test sanity --test ansible-doc --python 3.7 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:0:0: has a documentation error formatting or is missing documentation.

The test ansible-test sanity --test boilerplate [explain] failed with 9 errors:

lib/ansible/modules/monitoring/opsview_bsm_component.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_bsm_service.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_flow_source.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_host.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_host_group.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_login.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_reload.py:0:0: missing: from __future__ import (absolute_import, division, print_function)

The test ansible-test sanity --test compile --python 3.7 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:31: SyntaxError: opsview_client.reload(async=True)

The test ansible-test sanity --test compile --python 3.8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:27: SyntaxError: opsview_client.reload(async=True)

The test ansible-test sanity --test import --python 3.7 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:31: SyntaxError: invalid syntax

The test ansible-test sanity --test import --python 3.8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:27: SyntaxError: invalid syntax

The test ansible-test sanity --test pep8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:27: W606 'async' and 'await' are reserved keywords starting with Python 3.7

The test ansible-test sanity --test validate-modules [explain] failed with 41 errors:

lib/ansible/modules/monitoring/opsview_bsm_component.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_bsm_component.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_bsm_service.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_bsm_service.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_flow_source.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_flow_source.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'all_hosts' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'all_service_checks' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'enabled' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'all_hosts' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'all_service_checks' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'enabled' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'exclude_handled' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'public' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_host.py:0:0: E324 Argument 'snmp_max_msg_size' in argument_spec defines default as (None) but documentation defines default as (0)
lib/ansible/modules/monitoring/opsview_host.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'enable_snmp' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'event_handler_always_exec' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'flap_detection_enabled' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'rancid_auto_enable' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'snmp_extended_throughput_data' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'snmp_use_getnext' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'snmp_use_ifname' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'use_rancid' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host_group.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_host_group.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_login.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_login.py:0:0: E319 RETURN.opsview_version.type: not a valid value for dictionary value @ data['opsview_version']['type']. Got 'string'
lib/ansible/modules/monitoring/opsview_login.py:0:0: E319 RETURN.token.type: not a valid value for dictionary value @ data['token']['type']. Got 'string'
lib/ansible/modules/monitoring/opsview_login.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: E326 Argument 'ssh_forward' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E324 Argument 'force' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E326 Argument 'force' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E326 Argument 'wait' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])

click here for bot help

@ansibot ansibot added the ci_verified label Mar 6, 2019

Joshua Griffiths
@ansibot

This comment has been minimized.

Copy link
Contributor

commented Mar 6, 2019

The test ansible-test sanity --test ansible-doc --python 3.8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:0:0: has a documentation error formatting or is missing documentation.

The test ansible-test sanity --test ansible-doc --python 3.7 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:0:0: has a documentation error formatting or is missing documentation.

The test ansible-test sanity --test boilerplate [explain] failed with 9 errors:

lib/ansible/modules/monitoring/opsview_bsm_component.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_bsm_service.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_flow_source.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_host.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_host_group.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_login.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_reload.py:0:0: missing: from __future__ import (absolute_import, division, print_function)

The test ansible-test sanity --test compile --python 3.7 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:31: SyntaxError: opsview_client.reload(async=True)

The test ansible-test sanity --test compile --python 3.8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:27: SyntaxError: opsview_client.reload(async=True)

The test ansible-test sanity --test import --python 3.7 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:31: SyntaxError: invalid syntax

The test ansible-test sanity --test import --python 3.8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:27: SyntaxError: invalid syntax

The test ansible-test sanity --test pep8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:163:27: W606 'async' and 'await' are reserved keywords starting with Python 3.7

The test ansible-test sanity --test validate-modules [explain] failed with 41 errors:

lib/ansible/modules/monitoring/opsview_bsm_component.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_bsm_component.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_bsm_service.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_bsm_service.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_flow_source.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_flow_source.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'all_hosts' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'all_service_checks' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'enabled' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'all_hosts' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'all_service_checks' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'enabled' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'exclude_handled' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'public' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_host.py:0:0: E324 Argument 'snmp_max_msg_size' in argument_spec defines default as (None) but documentation defines default as (0)
lib/ansible/modules/monitoring/opsview_host.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'enable_snmp' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'event_handler_always_exec' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'flap_detection_enabled' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'rancid_auto_enable' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'snmp_extended_throughput_data' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'snmp_use_getnext' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'snmp_use_ifname' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'use_rancid' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host_group.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_host_group.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_login.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_login.py:0:0: E319 RETURN.opsview_version.type: not a valid value for dictionary value @ data['opsview_version']['type']. Got 'string'
lib/ansible/modules/monitoring/opsview_login.py:0:0: E319 RETURN.token.type: not a valid value for dictionary value @ data['token']['type']. Got 'string'
lib/ansible/modules/monitoring/opsview_login.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: E326 Argument 'ssh_forward' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E324 Argument 'force' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E326 Argument 'force' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E326 Argument 'wait' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])

click here for bot help

Joshua Griffiths added 2 commits Mar 6, 2019
Joshua Griffiths
Joshua Griffiths

@ansibot ansibot removed the ci_verified label Mar 6, 2019

@ansibot

This comment has been minimized.

Copy link
Contributor

commented Mar 6, 2019

The test ansible-test sanity --test ansible-doc --python 3.7 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:0:0: has a documentation error formatting or is missing documentation.

The test ansible-test sanity --test ansible-doc --python 3.8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:0:0: has a documentation error formatting or is missing documentation.

The test ansible-test sanity --test boilerplate [explain] failed with 9 errors:

lib/ansible/modules/monitoring/opsview_bsm_component.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_bsm_service.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_flow_source.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_host.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_host_group.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_login.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: missing: from __future__ import (absolute_import, division, print_function)
lib/ansible/modules/monitoring/opsview_reload.py:0:0: missing: from __future__ import (absolute_import, division, print_function)

The test ansible-test sanity --test compile --python 3.7 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:165:31: SyntaxError: opsview_client.reload(async=True)

The test ansible-test sanity --test compile --python 3.8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:165:27: SyntaxError: opsview_client.reload(async=True)

The test ansible-test sanity --test import --python 3.7 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:165:31: SyntaxError: invalid syntax

The test ansible-test sanity --test import --python 3.8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:165:27: SyntaxError: invalid syntax

The test ansible-test sanity --test pep8 [explain] failed with 1 error:

lib/ansible/modules/monitoring/opsview_reload.py:165:27: W606 'async' and 'await' are reserved keywords starting with Python 3.7

The test ansible-test sanity --test validate-modules [explain] failed with 45 errors:

lib/ansible/modules/monitoring/opsview_bsm_component.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_bsm_component.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_bsm_service.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_bsm_service.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_flow_source.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_flow_source.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'all_hosts' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'all_service_checks' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'enabled' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'all_hosts' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'all_service_checks' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'enabled' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'exclude_handled' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_hashtag.py:0:0: E326 Argument 'public' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_host.py:0:0: E324 Argument 'snmp_max_msg_size' in argument_spec defines default as (None) but documentation defines default as (0)
lib/ansible/modules/monitoring/opsview_host.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'enable_snmp' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'event_handler_always_exec' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'flap_detection_enabled' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'rancid_auto_enable' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'snmp_extended_throughput_data' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'snmp_use_getnext' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'snmp_use_ifname' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host.py:0:0: E326 Argument 'use_rancid' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_host_group.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_host_group.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_login.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_login.py:0:0: E319 RETURN.opsview_version.type: not a valid value for dictionary value @ data['opsview_version']['type']. Got 'string'
lib/ansible/modules/monitoring/opsview_login.py:0:0: E319 RETURN.token.type: not a valid value for dictionary value @ data['token']['type']. Got 'string'
lib/ansible/modules/monitoring/opsview_login.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_login.py:11:0: E106 Import found before documentation variables. All imports must appear below DOCUMENTATION/EXAMPLES/RETURN/ANSIBLE_METADATA.
lib/ansible/modules/monitoring/opsview_login.py:11:0: E107 Imports should be directly below DOCUMENTATION/EXAMPLES/RETURN/ANSIBLE_METADATA.
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_monitoring_server.py:0:0: E326 Argument 'ssh_forward' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E307 version_added should be '2.8'. Currently '2.5'
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E324 Argument 'force' in argument_spec defines default as (True) but documentation defines default as (False)
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E324 Argument 'verify_ssl' in argument_spec defines default as ('True') but documentation defines default as ('yes')
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E326 Argument 'force' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_reload.py:0:0: E326 Argument 'wait' in argument_spec defines choices as ([]) but documentation defines choices as ([True, False])
lib/ansible/modules/monitoring/opsview_reload.py:11:0: E106 Import found before documentation variables. All imports must appear below DOCUMENTATION/EXAMPLES/RETURN/ANSIBLE_METADATA.
lib/ansible/modules/monitoring/opsview_reload.py:11:0: E107 Imports should be directly below DOCUMENTATION/EXAMPLES/RETURN/ANSIBLE_METADATA.

click here for bot help

@ansibot ansibot added the ci_verified label Mar 6, 2019

@ansibot ansibot added the stale_ci label Mar 14, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.