Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Correct plugin loader context for persistent (#54860) #55172

Merged
merged 1 commit into from Apr 16, 2019

Conversation

Projects
None yet
3 participants
@bcoca
Copy link
Member

commented Apr 11, 2019

ISSUE TYPE
  • Bugfix Pull Request
COMPONENT NAME

connection/persistent

Correct plugin loader context for persistent (#54860)
* Correct plugin loader context for persistent

(cherry picked from commit 6579dfd)
@ansibot

This comment has been minimized.

@abadger
Copy link
Member

left a comment

When this was merged for 2.7, it broke the 2.7 connection tests. mattclay reports that it did not break on devel, though. Need someone to examine why it broke on 2.7 and make sure that that does not apply to stable-2.8 before merging this.

@abadger

This comment has been minimized.

Copy link
Member

commented Apr 15, 2019

The problem is become_plugins which is present in 2.8 but not in 2.7. This is safe to merge

Code examined, problem on 2.7 does not affect 2.8

@ansibot ansibot removed the needs_triage label Apr 15, 2019

@abadger abadger merged commit c975c0e into ansible:stable-2.8 Apr 16, 2019

1 check passed

Shippable Run 118899 status is SUCCESS.
Details
@abadger

This comment has been minimized.

Copy link
Member

commented Apr 16, 2019

Merged for the 2.8.0rc1 release.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.