Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix 56259 #56308

Open
wants to merge 4 commits into
base: devel
from

Conversation

Projects
None yet
5 participants
@acalm
Copy link
Contributor

commented May 10, 2019

SUMMARY

Fixes #56259
Also did some minor renaming of functions, added diff and minor re-org

ISSUE TYPE
  • Bugfix Pull Request
COMPONENT NAME

os_server

ADDITIONAL INFORMATION
@openstack-zuul

This comment has been minimized.

Copy link

commented May 10, 2019

Build succeeded (third-party-check pipeline).

acalm
@openstack-zuul

This comment has been minimized.

Copy link

commented May 10, 2019

Build succeeded (third-party-check pipeline).

@jamescassell
Copy link
Contributor

left a comment

LGTM, though I haven't tested it

@acalm

This comment has been minimized.

Copy link
Contributor Author

commented May 13, 2019

@josemgom and @gtema would you mind testing if this works for you?

@josemgom

This comment has been minimized.

Copy link

commented May 14, 2019

@josemgom and @gtema would you mind testing if this works for you?

Sure, I will test it and I will provide feedback as soon as possible.

Edit:

@acalm I just tested it and I am facing the same issue. Security groups seems to be added to the instance but only works if I run the task twice.

Screen Shot 2019-05-14 at 10 18 36

Below the Ansible config.

ansible-playbook 2.9.0.dev0 config file = /Users/myuser/mydocs/DevOps/team/stash/ansible-project/ansible.cfg configured module search path = [u'/Users/myuser/mydocs/DevOps/team/stash/ansible-project/library'] ansible python module location = /Users/myuser/mydocs/DevOps/team/stash/ansible/test/lib/python2.7/site-packages/ansible-2.9.0.dev0-py2.7.egg/ansible executable location = ../ansible/bin/ansible-playbook python version = 2.7.10 (default, Oct 6 2017, 22:29:07) [GCC 4.2.1 Compatible Apple LLVM 9.0.0 (clang-900.0.31)]

I am starting to think that the issue is on OpenStack side instead of Ansible.

Thanks in advance.

Cheers,
Jose

@acalm

This comment has been minimized.

Copy link
Contributor Author

commented May 15, 2019

@josemgom that's weird, I've tried it on both openstacksdk 3.14.1, 3.18.0 and python 2, 3. It might be openstack, however this change solved my problems on Queens.

What version are you running of openstack and openstacksdk?
Also, can you double check that the pr was actually checked out? (I miss this from time to time)

@josemgom

This comment has been minimized.

Copy link

commented May 15, 2019

@josemgom that's weird, I've tried it on both openstacksdk 3.14.1, 3.18.0 and python 2, 3. It might be openstack, however this change solved my problems on Queens.

What version are you running of openstack and openstacksdk?
Also, can you double check that the pr was actually checked out? (I miss this from time to time)

Yes, it is weird. I checked and I am working with your branch which contains the fix.

More details about my environment:
Openstack Version: Pike
openstacksdk==0.24.0
python-openstackclient==3.14.0
ansible==2.9.0.dev0

I tried to create a server with the openstack cli providing both security groups and works fine.

@acalm

This comment has been minimized.

Copy link
Contributor Author

commented May 16, 2019

I cannot reproduce the referenced issue any longer, this PR does contain some cleanups though so it might be an OK merge anyhow

@jillr jillr removed the needs_triage label May 16, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.