Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

a bug fix for elastic pool name #56820

Open
wants to merge 5 commits into
base: devel
from

Conversation

Projects
None yet
4 participants
@MyronFanQiu
Copy link
Contributor

commented May 23, 2019

SUMMARY

The Python SDK changed the parameter elastic_pool_name to the elastic_pool_id and cause the small bug for this module.
Ref:Azure/azure_preview_modules#268

ISSUE TYPE
  • Bugfix Pull Request
COMPONENT NAME

azure_rm_sqldatabase

ADDITIONAL INFORMATION

@ansibot

This comment has been minimized.

@ansibot

This comment has been minimized.

Copy link
Contributor

commented May 23, 2019

@MyronFanQiu, just so you are aware we have a dedicated Working Group for azure.
You can find other people interested in this in #ansible-azure on Freenode IRC
For more information about communities, meetings and agendas see https://github.com/ansible/community

click here for bot help

@ansibot

This comment has been minimized.

Copy link
Contributor

commented May 23, 2019

The test ansible-test sanity --test pep8 [explain] failed with 1 error:

lib/ansible/modules/cloud/azure/azure_rm_sqldatabase.py:499:1: E302 expected 2 blank lines, found 1

click here for bot help

@Fred-sun

This comment has been minimized.

Copy link
Contributor

commented Jun 5, 2019

@yungezz @yuwzho @zikalino Please help to review this PR when you're free! Thank you very much!

@yungezz

This comment has been minimized.

Copy link
Contributor

commented Jun 19, 2019

what version the change in SDK was introduced? what about user who using old version SDK?

@ansibot ansibot removed the needs_triage label Jun 19, 2019

@MyronFanQiu

This comment has been minimized.

Copy link
Contributor Author

commented Jun 19, 2019

what version the change in SDK was introduced? what about user who using old version SDK?

It's sorry that the sqldatabase SDK doesn't support mutil-API versions. Well, user should update both Ansible and SDK or not update both.

@MyronFanQiu

This comment has been minimized.

Copy link
Contributor Author

commented Jun 19, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.