Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Load Ansible module_utils for ps_argspec validator (#58571) - 2.8 #58614

Merged
merged 1 commit into from Jul 16, 2019

Conversation

Projects
None yet
3 participants
@jborean93
Copy link
Contributor

commented Jul 2, 2019

(cherry picked from commit c3978fe)

SUMMARY

Backport of #58571.

While this is technically a feature it's not a user facing issue and is being backported so the ansible-test code base is aligned between versions.

ISSUE TYPE
  • Feature Pull Request
COMPONENT NAME

validate-mdoules

Load Ansible module_utils for ps_argspec validator (#58571)
* Load Ansible module_utils for ps_argspec validator

* fix validation for modules without Requires statement

* Moved future comment to proper location

(cherry picked from commit c3978fe)
@ansibot

This comment has been minimized.

Copy link
Contributor

commented Jul 2, 2019

@abadger

This comment has been minimized.

Copy link
Member

commented Jul 16, 2019

We've decided that test changes are allowed to include new features in backports.

@abadger abadger merged commit e845089 into ansible:stable-2.8 Jul 16, 2019

1 check passed

Shippable Run 130392 status is SUCCESS.
Details
@abadger

This comment has been minimized.

Copy link
Member

commented Jul 16, 2019

Merged for the 2.8.3 release.

@jborean93 jborean93 deleted the jborean93:ps-validate-util-2.8 branch Jul 16, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.