New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The `prefixCls` feature of `Modal.info` method is incomplete #12546

Closed
concefly opened this Issue Oct 9, 2018 · 4 comments

Comments

Projects
None yet
4 participants
@concefly
Contributor

concefly commented Oct 9, 2018

  • I have searched the issues of this repository and believe that this is not a duplicate.

Version

3.10.0

Environment

5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

Reproduction link

Edit on CodeSandbox

Steps to reproduce

Just to invoke Modal.info with prefixCls: 'custom-confirm'.

What is expected?

I expect that all the rended DOMs are prefixed correctly instead of the content area of Modal.

What is actually happening?

image

@afc163

This comment has been minimized.

Member

afc163 commented Oct 9, 2018

Duplicate of #10855

@afc163 afc163 marked this as a duplicate of #10855 Oct 9, 2018

@afc163 afc163 closed this Oct 9, 2018

@concefly

This comment has been minimized.

Contributor

concefly commented Oct 9, 2018

Well, I'm resoling it now and commiting a PR.

@afc163

This comment has been minimized.

Member

afc163 commented Oct 9, 2018

just connect your PR to #10855

@zombieJ

This comment has been minimized.

Member

zombieJ commented Oct 9, 2018

Seems little different with #10855 . The prefixCls works as the content of Modal instead of Modal self.(history)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment