New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

build failed dependency conflict #8455

ChinaXing opened this Issue Dec 5, 2017 · 1 comment


None yet
2 participants

ChinaXing commented Dec 5, 2017




macOSX 17.2.0 Darwin Kernel Version 17.2.0

Reproduction link

Steps to reproduce

npm i 执行安装的时候

npm WARN react-slick@0.15.4 requires a peer of react@^0.14.0 || ^15.0.1 but none was installed.
npm WARN react-slick@0.15.4 requires a peer of react-dom@^0.14.0 || ^15.0.1 but none was installed.
npm WARN slick-carousel@1.8.1 requires a peer of jquery@>=1.8.0 but none was installed.

antd 3.0.0 依赖 react >= 16
antd 3.0.0 依赖的 react-slike 依赖 react: '^0.14.0 || ^15.0.1'

What is expected?


What is actually happening?

出现WARN 表示peer dependency 不满足


This comment has been minimized.


afc163 commented Dec 5, 2017

akiran/react-slick#866 react-slick 还没发新版本。

问题不大,这个只是 warning,不影响使用。

@afc163 afc163 closed this in d7dcb56 Dec 11, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment