Skip to content

(pushed gmpy2 version to aleaxit/gmpy@b6a8ea6)

select and download necessary files for your python version from above (pplpy_dependencies-0.0.1, gmpy2 and pplpy-0.7)
and installing them with pip as described here.

  • For Ubuntu 16.04: Download packages for python3.5
  • For Ubuntu 18.04: Download packages for python3.6
Assets 12
Pre-release

@antielektron antielektron released this Jul 8, 2018 · 2 commits to master since this release

select and download necessary files for your python version from above (pplpy_dependencies-0.0.1, gmpy2 and pplpy-0.7)
and installing them with pip as described here.

  • For Ubuntu 14.04: Not officially supported since it needs a few hacks to the script, but experimental builds are here
  • For Ubuntu 16.04: Download packages for python3.5
  • For Ubuntu 18.04: Download packages for python3.6
Assets 12
Pre-release
Pre-release

@antielektron antielektron released this May 15, 2018 · 12 commits to master since this release

Note: this release is an early preview. It's main purpose is to provide pregenerated wheels for pplpy. Therefore there are 3 packages:

  • pplpy-dependencies: contains all shared libraries needed by gmpy2 and pplpy

  • gmpy2: wheel for gmpy2, provided for Python/Cython v3.5 and v3.6

  • pplpy: wheel for pplpy, provided for Python/Cython v3.5 and v3.6


to install these wheels on ubuntu, just do the following steps:

  • install cython and cysignals:
sudo -H pip3 install cython cysignals

then installing the wheels

  • for ubuntu 16.04:
sudo -H pip3 install https://github.com/antielektron/pplpy_wheel_builder_script/releases/download/v0.2/pplpy_dependencies-0.0.1-py3-none-any.whl https://github.com/antielektron/pplpy_wheel_builder_script/releases/download/v0.2/gmpy2-2.1.0a1-cp35-cp35m-linux_x86_64.whl https://github.com/antielektron/pplpy_wheel_builder_script/releases/download/v0.2/pplpy-0.7-cp35-cp35m-linux_x86_64.whl
  • for ubuntu 18.04:
sudo -H pip3 install https://github.com/antielektron/pplpy_wheel_builder_script/releases/download/v0.2/pplpy_dependencies-0.0.1-py3-none-any.whl https://github.com/antielektron/pplpy_wheel_builder_script/releases/download/v0.2/gmpy2-2.1.0a1-cp36-cp36m-linux_x86_64.whl https://github.com/antielektron/pplpy_wheel_builder_script/releases/download/v0.2/pplpy-0.7-cp36-cp36m-linux_x86_64.whl
Assets 7
You can’t perform that action at this time.