Permalink
Browse files

* swank-ecl.lisp: Make backend depend on ECL version 10.3.1 which

	just got released. We do not support older versions. Previous
	version pretty much didn't work in combination with Slime anyway.
  • Loading branch information...
1 parent 8851620 commit cc446f7fb76eb59795d38db895e5f69031f26cac @trittweiler trittweiler committed Mar 5, 2010
Showing with 8 additions and 2 deletions.
  1. +6 −0 ChangeLog
  2. +2 −2 swank-ecl.lisp
View
@@ -1,5 +1,11 @@
2010-03-05 Tobias C. Rittweiler <tcr@freebits.de>
+ * swank-ecl.lisp: Make backend depend on ECL version 10.3.1 which
+ just got released. We do not support older versions. Previous
+ version pretty much didn't work in combination with Slime anyway.
+
+2010-03-05 Tobias C. Rittweiler <tcr@freebits.de>
+
Ecl: Make M-. work on function interactively compiled via C-c C-c.
* swank-ecl.lisp (*tmpfile-map*, note-buffer-tmpfile)
View
@@ -12,10 +12,10 @@
(eval-when (:compile-toplevel :load-toplevel :execute)
(let ((version (find-symbol "+ECL-VERSION-NUMBER+" :EXT)))
- (when (or (not version) (< (symbol-value version) 100201))
+ (when (or (not version) (< (symbol-value version) 100301))
(error "~&IMPORTANT:~% ~
The version of ECL you're using (~A) is too old.~% ~
- Please upgrade to at least 10.2.1.~% ~
+ Please upgrade to at least 10.3.1.~% ~
Sorry for the inconvenience.~%~%"
(lisp-implementation-version)))))

0 comments on commit cc446f7

Please sign in to comment.