New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

@user_script:6: Bad data format in input. #51

Closed
phlegx opened this Issue Apr 18, 2016 · 1 comment

Comments

Projects
None yet
1 participant
@phlegx

phlegx commented Apr 18, 2016

Hi! I use Redis v2.8.4 and Ruby redis-rb v3.2.2 gem as client. I get this error if I want to pack and unpack messages: @user_script:6: Bad data format in input.

  • pack with Ruby msgpack v0.7.2 (all works fine with version 0.5.12)
  • unpack with cmsgpack in lua on Redis v2.8.4

Ruby msgpack v0.5.12

{ a: 'dc127424-e201-463c-9b41-f5b927ecd947' }.to_msgpack
=> "\x81\xA1a\xDA\x00$dc127424-e201-463c-9b41-f5b927ecd947" 

Ruby msgpack v0.7.2

{ a: 'dc127424-e201-463c-9b41-f5b927ecd947' }.to_msgpack
=> "\x81\xA1a\xD9$dc127424-e201-463c-9b41-f5b927ecd947" 

Here my Redis INFO output:

redis_version:2.8.4
redis_git_sha1:00000000
redis_git_dirty:0
redis_build_id:a44a05d76f06a5d9
redis_mode:standalone
os:Linux 3.16.0-70-generic x86_64
arch_bits:64
multiplexing_api:epoll
gcc_version:4.8.2
...

I have read this #44 and seen that Redis v2.8.4 uses lua-cmsgpack 0.4.0 where this problem is solved (dec1810) but not in my case. Any idea?

@phlegx

This comment has been minimized.

Show comment
Hide comment
@phlegx

phlegx Apr 18, 2016

OK, Redis starting from version 2.8.18 uses lua-cmsgpack 0.4.0!

phlegx commented Apr 18, 2016

OK, Redis starting from version 2.8.18 uses lua-cmsgpack 0.4.0!

@phlegx phlegx closed this Apr 18, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment