Starting redis-server: failed(some common faults) #818

Closed
tourmaline612 opened this Issue Dec 7, 2012 · 9 comments

Comments

Projects
None yet
8 participants

I have tried some times but it still doesn't work. why??

Collaborator

badboy commented Dec 7, 2012

See the log output.

Contributor

charsyam commented Dec 7, 2012

@tourmaline612 show me more information about that error.

if you mean start script failure when linux is boot.

maybe it can be related with #807 this issue

Contributor

bmcmanus commented Dec 8, 2012

@tourmaline612

This ticket is a bit vague could you please paste the console output?
Additionally,could you please attach your /etc/init.d/redis_6379 file?

Did you execute "bash install_server.sh" instead of ./install_server.sh? Bash interpreting this script creates a literal header ie

#/bin/sh\n #Configurations injected by install_server below....\n\n EXEC=/usr/local/bin/redis-server\n CLIEXEC=/usr/local/bin/redis-cli\n PIDFILE=/var/run/redis_6379.pid\n CONF="/etc/redis/6379.conf"\n\n REDISPORT="6379"\n\n ###############\n\n"

I don't have a RedHat distribution handy but I imagine a literal header like this would cause many problems. If we believe this is init related please attach your /etc/init.d/redis_* file.

Thank you.

Thank you! I have solved the problem.

ÔÚ 2012-12-07 21:57:11£¬"Jan-Erik Rediger" notifications@github.com дµÀ£º

See the log output.

¡ª
Reply to this email directly or view it on GitHub.

Thank you! I have solved the problem.

At 2012-12-08 00:23:00,charsyam notifications@github.com wrote:

@tourmaline612 show me more information about that error.

if you mean start script failure when linux is boot.

maybe it can be related with #807 this issue

¡ª
Reply to this email directly or view it on GitHub.

Thank you! I have solved the problem.

At 2012-12-08 13:22:50,"Brian McManus" notifications@github.com wrote:

@tourmaline612

This ticket is a bit vague could you please paste the console output?
Additionally,could you please attach your /etc/init.d/redis_6379 file?

Did you execute "bash install_server.sh" instead of ./install_server.sh? Bash interpreting this script creates a literal header ie

#/bin/sh\n #Configurations injected by install_server below....\n\n EXEC=/usr/local/bin/redis-server\n CLIEXEC=/usr/local/bin/redis-cli\n PIDFILE=/var/run/redis_6379.pid\n CONF="/etc/redis/6379.conf"\n\n REDISPORT="6379"\n\n ###############\n\n"

I don't have a RedHat distribution handy but I imagine a literal header like this would cause many problems. If we believe this is init releated please attach your /etc/init.d/redis_* file.

Thank you.

¡ª
Reply to this email directly or view it on GitHub.

antirez closed this Dec 12, 2012

How did you solve the problem?

Yes. Even m facing a similar problem. Here is how my console looks.

yasser@yasser-VirtualBox:~$ sudo service redis-server start
Starting redis-server: failed

ThaJay commented Oct 12, 2015

same error. my log file (at "/var/log/redis/") is empty.
I'm on ubuntu 14.04. This is probably something very simple but haven't found it yet

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment