New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Password causing segmentation fault in 2.6.10? #985

Closed
radekg opened this Issue Mar 5, 2013 · 2 comments

Comments

Projects
None yet
2 participants
@radekg

radekg commented Mar 5, 2013

Hi,
I was installing redis on a brand new box just like 5 mins ago.
I was trying to set a strong autogenerated password. This is an example:

!b`Bs6/9i5xNo(`gh\&S!$'$

When I set this pass I get:

Segmentation fault (core dumped)

When running:

sudo -u redis /opt/redis/bin/redis-server /opt/redis/redis.conf

Not getting the same error when using another strong password, for example this isn't causing an error:

G#`39Q0ouLq/2>4sP6LV;D#c
@antirez

This comment has been minimized.

Show comment
Hide comment
@antirez

antirez Mar 5, 2013

Owner

Hello, this is a known bug about unbalanced ' character. I've already a fix that I'll merge in the next days. Thanks for reporting.

Owner

antirez commented Mar 5, 2013

Hello, this is a known bug about unbalanced ' character. I've already a fix that I'll merge in the next days. Thanks for reporting.

@radekg

This comment has been minimized.

Show comment
Hide comment
@radekg

radekg Mar 5, 2013

cool, cheers

radekg commented Mar 5, 2013

cool, cheers

@radekg radekg closed this Mar 5, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment