Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
tree: 4f23cbf9ff
Fetching contributors…

Cannot retrieve contributors at this time

119 lines (96 sloc) 3.576 kB
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>org.antlr</groupId>
<artifactId>antlr</artifactId>
<packaging>jar</packaging>
<name>ANTLR Grammar Tool v 3.4</name>
<url>http://antlr.org</url>
<!--
Inherit from the ANTLR master pom, which tells us what
version we are and allows us to inherit dependencies
and so on.
-->
<parent>
<groupId>org.antlr</groupId>
<artifactId>antlr-master</artifactId>
<version>3.4</version>
</parent>
<profiles>
<profile>
<id>uber</id>
<activation>
<property>
<name>uber</name>
<value>true</value>
</property>
</activation>
<dependencies>
<dependency>
<groupId>org.antlr</groupId>
<artifactId>gunit</artifactId>
<version>${project.version}</version>
<scope>runtime</scope>
</dependency>
</dependencies>
</profile>
</profiles>
<dependencies>
<dependency>
<groupId>org.antlr</groupId>
<artifactId>antlr-runtime</artifactId>
<version>${project.version}</version>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.8.2</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>org.antlr</groupId>
<artifactId>ST4</artifactId>
<version>4.0.4</version>
<scope>compile</scope>
</dependency>
</dependencies>
<!--
Tell Maven which other artifacts we need in order to
build, run and test the ANTLR Tool. The ANTLR Tool uses earlier versions
of ANTLR at runtime (for the moment), uses the current
released version of ANTLR String template, but obviously is
reliant on the latest snapshot of the runtime, which will either be
taken from the antlr-snapshot repository, or your local .m2
repository if you built and installed that locally.
-->
<build>
<defaultGoal>install</defaultGoal>
<plugins>
<plugin>
<groupId>org.antlr</groupId>
<artifactId>antlr3-maven-plugin</artifactId>
<version>3.3</version>
<configuration>
<libDirectory>target/generated-sources/antlr/org/antlr/grammar/v3</libDirectory>
</configuration>
<executions>
<execution>
<goals>
<goal>antlr</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<artifactId>maven-compiler-plugin</artifactId>
<version>2.3.2</version>
<configuration>
<source>1.6</source>
<target>jsr14</target>
<sourceDirectory>src</sourceDirectory>
</configuration>
</plugin>
</plugins>
</build>
</project>
Jump to Line
Something went wrong with that request. Please try again.