Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

BPM off / tempo deviating #5

Closed
antonhornquist opened this issue Apr 11, 2019 · 4 comments

Comments

Projects
None yet
2 participants
@antonhornquist
Copy link
Owner

commented Apr 11, 2019

something to look into.

from carvingcode on lines:

"After 1 to 1.5 measures, it is noticeable. This is with or without swing."

"I tested against a metronome app and another norns app at 60 BPM."

"May be happening in rounding error in update_swing(). Shouldn’t swing value only be applied to the odd?"

@antonhornquist antonhornquist added the bug label Apr 11, 2019

@simonvanderveldt

This comment has been minimized.

Copy link

commented Apr 11, 2019

Just compared at 62BPM vs 62BPM on software MIDI sequence/synth and those drifted, sequencer was a bit faster.
Not sure I'm hearing a lot of variation though. Could it be reverb that makes it sound like that? With (system) reverb off it seems pretty stable for me.

@antonhornquist

This comment has been minimized.

Copy link
Owner Author

commented Apr 12, 2019

i could recreate this yesterday. i initially thought tempo was deviating in that it changed after some measure, but can conclude that the tempo appear to stay constant but it is not the tempo that is displayed in the UI.

I tested by running Renoise @ 60 BPM and compared to Step @ 60 BPM, and as reported, immediately (after a bar or so) the difference can be heard. Lowering tempo in Renoise to 58 BPM would sync Renoise and Step up better but after some time the difference is heard still.

I'll investigate this further.

Thanks @carvingCode for finding this.

@antonhornquist

This comment has been minimized.

Copy link
Owner Author

commented Apr 13, 2019

i found a bug in tick() today that caused this. I will have a fix ready for this in next version of Step.

@antonhornquist

This comment has been minimized.

Copy link
Owner Author

commented Apr 14, 2019

fix in 2ca2e71

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.