Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Keka hangs when server not available #440

Open
gabrielwhite opened this issue Aug 29, 2019 · 5 comments

Comments

@gabrielwhite
Copy link

commented Aug 29, 2019

I last used Keka to do some file operation on an SMB server.

I changed the name of the server since then.

When I open Keka now, I get an error "NAS - Files not available" and Keka hangs.

I fixed the issue by doing an application reset with CleanMyMac.

@issuelabeler issuelabeler bot added the fixed label Aug 29, 2019

@gabrielwhite

This comment has been minimized.

Copy link
Author

commented Aug 29, 2019

I'm using 1.1.17

@aonez aonez self-assigned this Sep 2, 2019

@aonez aonez added core performance and removed fixed labels Sep 2, 2019

@aonez aonez added this to the Look at milestone Sep 2, 2019

@aonez

This comment has been minimized.

Copy link
Owner

commented Sep 2, 2019

@gabrielwhite thanks for that one!

Most probably Keka created a bookmark to a path where you've done some operations and is trying to resolve this. I'll do some tests.

@aonez

This comment has been minimized.

Copy link
Owner

commented Sep 2, 2019

By the way, where do you got that one:

NAS - Files not available"

It was from Keka or from the OS? Are you using any specific NAS software?

@gabrielwhite

This comment has been minimized.

Copy link
Author

commented Sep 2, 2019

I think it was an OS error, but I can't remember 100% (and I've since fixed the problem, so can't recreate)

@aonez

This comment has been minimized.

Copy link
Owner

commented Sep 2, 2019

Did some tests using a SMB shared folder. Can't reproduce the issue. If you reproduce this one again (in case you need to change the name again).

Also let me know if there's any third party software installed that comes with your NAS (in case you're using a NAS). This may be the key.

Thanks @gabrielwhite!

@aonez aonez added the works for me label Sep 2, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.