Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Keka hangs when opening .zip and .7z files at the same time #442

Open
jrgibson opened this issue Sep 9, 2019 · 9 comments

Comments

@jrgibson
Copy link

commented Sep 9, 2019

I'm a professor, so I'll frequently get a dozen compressed files from students that I want to decompress. If these are all one kind of archive (i.e., .zip), I can select them all in Finder, press Command-O, and they will decompress fine. However, if a .7z is included with those .zip files, Keka hangs.

I set Keka's preferences to Always Extract, and it still hangs when opening one .zip at the same time as one .7z.

(I'm sorry if this is a repeat issue. I didn't find it when looking through the reported errors.)

@aonez

This comment has been minimized.

Copy link
Owner

commented Sep 9, 2019

Hi @jrgibson,

When you say "hangs", you mean Keka is frozen?

You could try to remove the Keka preferences and try again, usually this solves this kind of issues. Just open the Terminal.app and execute the following command:

rm ~/Library/Containers/com.aone.keka

@aonez aonez self-assigned this Sep 9, 2019

@aonez aonez added this to the 1.1.20 milestone Sep 9, 2019

@gingerbeardman

This comment has been minimized.

Copy link
Contributor

commented Sep 9, 2019

Just trying to reproduce.

This set of files were extracted just fine with Keka using Cmd+O.

Screen shot 2019-09-09 at 10 39 14

@jrgibson

This comment has been minimized.

Copy link
Author

commented Sep 9, 2019

@no-response no-response bot removed the more info needed label Sep 9, 2019

@gingerbeardman

This comment has been minimized.

Copy link
Contributor

commented Sep 9, 2019

@jrgibson they both extract fine for me (select both, then Cmd+O)

Video: https://imgur.com/CmwupL8

@jrgibson

This comment has been minimized.

Copy link
Author

commented Sep 10, 2019

@aonez

This comment has been minimized.

Copy link
Owner

commented Sep 10, 2019

@jrgibson no problem here too. Maybe there's some write access issue? Like you're trying to extract those files in a read only disk? Like a NTFS formatted external disk?

Anyway, just enable the verbose mode and lets take a look at the logs in the Console.app:

defaults write com.aone.keka DevLog -bool TRUE
defaults write com.aone.keka DevLogReader -bool TRUE

@aonez aonez added the works for me label Sep 10, 2019

@jrgibson

This comment has been minimized.

Copy link
Author

commented Sep 10, 2019

@aonez

This comment has been minimized.

Copy link
Owner

commented Sep 10, 2019

@jrgibson It seems like Keka is not opening, that's right? Can you remove and download again Keka and restart your Mac if it's been a while since you do it? Let me know if this solves the issue.

@aonez

This comment has been minimized.

Copy link
Owner

commented Sep 10, 2019

If you open Keka (without invoking any file) and then drop the file in the window, it hangs too?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.