Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

window stays open after extraction #471

Open
getmonyinfo opened this issue Oct 28, 2019 · 7 comments
Assignees
Milestone

Comments

@getmonyinfo
Copy link

@getmonyinfo getmonyinfo commented Oct 28, 2019

current version: 1.1.21 (3378)
The window stays open after extraction, i have checked “Close keka when no windows are open"

@aonez aonez added the duplicated label Oct 28, 2019
@aonez aonez self-assigned this Oct 28, 2019
@aonez aonez added this to the 1.1.21 milestone Oct 28, 2019
@aonez

This comment has been minimized.

Copy link
Owner

@aonez aonez commented Oct 28, 2019

This is a dupe of #307. Can you uncheck and check "Close Keka when no windows are open". If this does not solve the issue, just reset the Keka preferences. Close Keka and then execute this command in the Terminal.app:

k='com.aone.keka'; rm ~/Library/Preferences/$k; rm -r ~/Library/Containers/$k;
@aonez aonez closed this Oct 28, 2019
@aonez aonez modified the milestones: 1.1.21, 1.1.22 Oct 28, 2019
@getmonyinfo

This comment has been minimized.

Copy link
Author

@getmonyinfo getmonyinfo commented Oct 28, 2019

I follow you steps:

  1. uncheck and check "Close Keka when no windows are open" no lucky
  2. k='com.aone.keka'; rm ~/Library/Preferences/$k; rm -r ~/Library/Containers/$k; no lucky
  3. reinstall keka no lucky

any tips to debug why not working?

@aonez aonez reopened this Oct 28, 2019
@aonez

This comment has been minimized.

Copy link
Owner

@aonez aonez commented Oct 28, 2019

Can you share a video capture of the issue? (for example capture the screen using QuickTime)

Also please try the latest beta version and let me know if has the issue too: https://beta.keka.io

@getmonyinfo

This comment has been minimized.

Copy link
Author

@getmonyinfo getmonyinfo commented Oct 29, 2019

a demo video

@aonez

This comment has been minimized.

Copy link
Owner

@aonez aonez commented Oct 29, 2019

Thanks a lot for the video @getmonyinfo. This one remembers me a lot to #38 (demo video) that was caused by a SIMBL plugin (afloat). But again this was already fixed.

Can you reproduce the issue with this build and let me know what messages Keka prints in the Console.app? Mostly I need the order of the printed messages starting with --, like:

default	11:36:19.473211 +0100	Keka	-- applicationWillBecomeActive

Also please try the latest beta, since it behaves different from the current stable releases, and I'm mostly sure it will work there: Keka v1.2.0-dev.3575


For resetting Keka preferences you only need to delete the container folder:

rm -r ~/Library/Containers/com.aone.keka

The first time you opened Keka it loaded with the legacy toolbar and when you clicked on the Preferences menu option it did not opened and the second time opened without loading any content, so that tells me maybe the find command did not worked as expected.

@aonez aonez added bug core gui and removed duplicated labels Oct 29, 2019
@aonez

This comment has been minimized.

Copy link
Owner

@aonez aonez commented Oct 29, 2019

any tips to debug why not working?

You can also get more Keka logs if you want: https://github.com/aonez/Keka/wiki/Console-verbose

@aonez aonez added more info needed and removed bug labels Nov 7, 2019
@aonez

This comment has been minimized.

Copy link
Owner

@aonez aonez commented Nov 7, 2019

@getmonyinfo where you able to test the build? Does this issue still happens for you?

@aonez aonez modified the milestones: 1.1.22, 1.1.23 Nov 12, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.