Skip to content
Permalink
Browse files
Revert to Java 8 for accumulo-testing
Allow accumulo-testing to build and run with Java 8, but support the
release flag on JDK9 and later.
  • Loading branch information
ctubbsii committed Jul 30, 2019
1 parent b3a3823 commit 2b7b28f73cac698e1724ad60311d2002fb4e02ae
Showing 1 changed file with 11 additions and 3 deletions.
14 pom.xml
@@ -31,9 +31,8 @@
<accumulo.version>2.0.0-SNAPSHOT</accumulo.version>
<eclipseFormatterStyle>${project.basedir}/contrib/Eclipse-Accumulo-Codestyle.xml</eclipseFormatterStyle>
<hadoop.version>3.2.0</hadoop.version>
<maven.compiler.release>11</maven.compiler.release>
<maven.compiler.source>11</maven.compiler.source>
<maven.compiler.target>11</maven.compiler.target>
<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>
<slf4j.version>1.7.25</slf4j.version>
<spotbugs.version>3.1.7</spotbugs.version>
<zookeeper.version>3.4.14</zookeeper.version>
@@ -351,5 +350,14 @@
</plugins>
</build>
</profile>
<profile>
<id>jdk-release-flag</id>
<activation>
<jdk>[9,)</jdk>
</activation>
<properties>
<maven.compiler.release>8</maven.compiler.release>
</properties>
</profile>
</profiles>
</project>

0 comments on commit 2b7b28f

Please sign in to comment.