Skip to content
Permalink
Browse files
ARTEMIS-3783: rationalise config for alternate jakarta spec versions …
…to simplify and align their use
  • Loading branch information
gemmellr committed Apr 20, 2022
1 parent e97e239 commit 6eb78a26348db54164128c32c7321f1a8ae23c35
Showing 6 changed files with 14 additions and 19 deletions.
@@ -29,7 +29,7 @@

<properties>
<activemq.basedir>${project.basedir}/..</activemq.basedir>
<jakarta.jms-api.version>3.0.0</jakarta.jms-api.version>
<jakarta.jms-api.version>${jakarta.jms-api.version.alt}</jakarta.jms-api.version>
</properties>

<dependencies>
@@ -29,7 +29,7 @@

<properties>
<activemq.basedir>${project.basedir}/..</activemq.basedir>
<jakarta.jms-api.version>3.0.0</jakarta.jms-api.version>
<jakarta.jms-api.version>${jakarta.jms-api.version.alt}</jakarta.jms-api.version>
</properties>

<dependencies>
@@ -64,7 +64,6 @@
<dependency>
<groupId>jakarta.jms</groupId>
<artifactId>jakarta.jms-api</artifactId>
<version>${jakarta.jms-api.version}</version>
</dependency>

<dependency>
@@ -29,9 +29,9 @@

<properties>
<activemq.basedir>${project.basedir}/..</activemq.basedir>
<jakarta.jms-api.version>3.0.0</jakarta.jms-api.version>
<jakarta.transaction-api.version>2.0.0</jakarta.transaction-api.version>
<jakarta.resource-api.version>2.0.0</jakarta.resource-api.version>
<jakarta.jms-api.version>${jakarta.jms-api.version.alt}</jakarta.jms-api.version>
<jakarta.transaction-api.version>${jakarta.transaction-api.version.alt}</jakarta.transaction-api.version>
<jakarta.resource-api.version>${jakarta.resource-api.version.alt}</jakarta.resource-api.version>
</properties>


@@ -67,19 +67,16 @@
<dependency>
<groupId>jakarta.resource</groupId>
<artifactId>jakarta.resource-api</artifactId>
<version>${jakarta.resource-api.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>jakarta.transaction</groupId>
<artifactId>jakarta.transaction-api</artifactId>
<version>${jakarta.transaction-api.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>jakarta.jms</groupId>
<artifactId>jakarta.jms-api</artifactId>
<version>${jakarta.jms-api.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
@@ -29,9 +29,9 @@

<properties>
<activemq.basedir>${project.basedir}/..</activemq.basedir>
<jakarta.jms-api.version>3.0.0</jakarta.jms-api.version>
<jakarta.transaction-api.version>2.0.0</jakarta.transaction-api.version>
<jakarta.resource-api.version>2.0.0</jakarta.resource-api.version>
<jakarta.jms-api.version>${jakarta.jms-api.version.alt}</jakarta.jms-api.version>
<jakarta.transaction-api.version>${jakarta.transaction-api.version.alt}</jakarta.transaction-api.version>
<jakarta.resource-api.version>${jakarta.resource-api.version.alt}</jakarta.resource-api.version>
</properties>

<dependencies>
@@ -84,12 +84,10 @@
<dependency>
<groupId>jakarta.jms</groupId>
<artifactId>jakarta.jms-api</artifactId>
<version>${jakarta.jms-api.version}</version>
</dependency>
<dependency>
<groupId>jakarta.transaction</groupId>
<artifactId>jakarta.transaction-api</artifactId>
<version>${jakarta.transaction-api.version}</version>
</dependency>
</dependencies>

@@ -29,8 +29,8 @@

<properties>
<activemq.basedir>${project.basedir}/..</activemq.basedir>
<jakarta.jms-api.version>3.0.0</jakarta.jms-api.version>
<jakarta.transaction-api.version>2.0.0</jakarta.transaction-api.version>
<jakarta.jms-api.version>${jakarta.jms-api.version.alt}</jakarta.jms-api.version>
<jakarta.transaction-api.version>${jakarta.transaction-api.version.alt}</jakarta.transaction-api.version>
</properties>

<dependencies>
@@ -78,12 +78,10 @@
<dependency>
<groupId>jakarta.transaction</groupId>
<artifactId>jakarta.transaction-api</artifactId>
<version>${jakarta.transaction-api.version}</version>
</dependency>
<dependency>
<groupId>jakarta.jms</groupId>
<artifactId>jakarta.jms-api</artifactId>
<version>${jakarta.jms-api.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
@@ -165,8 +165,11 @@
<testcontainers.version>1.16.3</testcontainers.version>
<exec-maven-plugin.version>3.0.0</exec-maven-plugin.version>

<!-- for JakrtaEE -->
<!-- for JakartaEE -->
<version.batavia>1.0.10.Final</version.batavia>
<jakarta.jms-api.version.alt>3.0.0</jakarta.jms-api.version.alt>
<jakarta.transaction-api.version.alt>2.0.0</jakarta.transaction-api.version.alt>
<jakarta.resource-api.version.alt>2.0.0</jakarta.resource-api.version.alt>

<!-- used on tests -->
<groovy.version>4.0.0</groovy.version>

0 comments on commit 6eb78a2

Please sign in to comment.