Skip to content
Permalink
Browse files
persist resolution results
  • Loading branch information
rotty3000 committed May 1, 2022
1 parent 825f398 commit 55fd9fca09ab9a44ffc7d79537b2e299422caa34
Showing 11 changed files with 89 additions and 86 deletions.
@@ -58,14 +58,14 @@ java.9.plus.reqs: \
org.apache.aries.jax.rs.jaxb.json.cxf-jettison;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.jaxb.json.cxf-jettison-itest-tests;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.whiteboard;version='[2.0.2,2.0.3)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.4,1.3.5)',\
org.apache.cxf.cxf-core;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-extension-providers;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-security;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.1,3.5.2)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.5,1.3.6)',\
org.apache.cxf.cxf-core;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-extension-providers;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-security;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.2,3.5.3)',\
org.apache.felix.configadmin;version='[1.9.24,1.9.25)',\
org.apache.felix.http.jetty;version='[4.2.0,4.2.1)',\
org.apache.felix.http.servlet-api;version='[1.2.0,1.2.1)',\
@@ -64,13 +64,13 @@ java.9.plus.reqs: \
org.apache.aries.jax.rs.jackson;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.jackson.itest-tests;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.whiteboard;version='[2.0.2,2.0.3)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.4,1.3.5)',\
org.apache.cxf.cxf-core;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-security;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.1,3.5.2)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.5,1.3.6)',\
org.apache.cxf.cxf-core;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-security;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.2,3.5.3)',\
org.apache.felix.configadmin;version='[1.9.24,1.9.25)',\
org.apache.felix.http.jetty;version='[4.2.0,4.2.1)',\
org.apache.felix.http.servlet-api;version='[1.2.0,1.2.1)',\
@@ -56,32 +56,32 @@ java.9.plus.reqs: \
org.apache.aries.spifly.auto.providers=com.sun.*

-runbundles: \
com.fasterxml.jackson.core.jackson-annotations;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.core.jackson-core;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.core.jackson-databind;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.dataformat.jackson-dataformat-yaml;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.datatype.jackson-datatype-jsr310;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.core.jackson-annotations;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.core.jackson-core;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.core.jackson-databind;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.dataformat.jackson-dataformat-yaml;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.datatype.jackson-datatype-jsr310;version='[2.13.2,2.13.3)',\
com.fasterxml.woodstox.woodstox-core;version='[6.2.7,6.2.8)',\
io.github.classgraph.classgraph;version='[4.8.95,4.8.96)',\
io.swagger.core.v3.swagger-annotations;version='[2.1.11,2.1.12)',\
io.swagger.core.v3.swagger-core;version='[2.1.11,2.1.12)',\
io.swagger.core.v3.swagger-integration;version='[2.1.11,2.1.12)',\
io.swagger.core.v3.swagger-jaxrs2;version='[2.1.11,2.1.12)',\
io.swagger.core.v3.swagger-models;version='[2.1.11,2.1.12)',\
io.github.classgraph.classgraph;version='[4.8.138,4.8.139)',\
io.swagger.core.v3.swagger-annotations;version='[2.2.0,2.2.1)',\
io.swagger.core.v3.swagger-core;version='[2.2.0,2.2.1)',\
io.swagger.core.v3.swagger-integration;version='[2.2.0,2.2.1)',\
io.swagger.core.v3.swagger-jaxrs2;version='[2.2.0,2.2.1)',\
io.swagger.core.v3.swagger-models;version='[2.2.0,2.2.1)',\
jakarta.validation.jakarta.validation-api;version='[2.0.2,2.0.3)',\
jakarta.xml.bind-api;version='[2.3.3,2.3.4)',\
org.apache.aries.component-dsl.component-dsl;version='[1.2.2,1.2.3)',\
org.apache.aries.jax.rs.openapi.itest-tests;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.openapi.resource;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.whiteboard;version='[2.0.2,2.0.3)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.4,1.3.5)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.5,1.3.6)',\
org.apache.commons.lang3;version='[3.12.0,3.12.1)',\
org.apache.cxf.cxf-core;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-security;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-core;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-security;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.2,3.5.3)',\
org.apache.felix.configadmin;version='[1.9.24,1.9.25)',\
org.apache.felix.http.jetty;version='[4.2.0,4.2.1)',\
org.apache.felix.http.servlet-api;version='[1.2.0,1.2.1)',\
@@ -92,7 +92,7 @@ java.9.plus.reqs: \
org.osgi.service.jaxrs;version='[1.0.1,1.0.2)',\
org.osgi.util.function;version='[1.2.0,1.2.1)',\
org.osgi.util.promise;version='[1.2.0,1.2.1)',\
org.yaml.snakeyaml;version='[1.27.0,1.27.1)',\
org.yaml.snakeyaml;version='[1.30.0,1.30.1)',\
stax2-api;version='[4.2.1,4.2.2)'

-runstartlevel: \
@@ -68,21 +68,21 @@ java.9.plus.reqs: \

-runbundles: \
assertj-core;version='[3.22.0,3.22.1)',\
com.fasterxml.jackson.core.jackson-annotations;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.core.jackson-core;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.core.jackson-databind;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.dataformat.jackson-dataformat-yaml;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.datatype.jackson-datatype-jsr310;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.jaxrs.jackson-jaxrs-base;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.jaxrs.jackson-jaxrs-json-provider;version='[2.12.1,2.12.2)',\
com.fasterxml.jackson.core.jackson-annotations;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.core.jackson-core;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.core.jackson-databind;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.dataformat.jackson-dataformat-yaml;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.datatype.jackson-datatype-jsr310;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.jaxrs.jackson-jaxrs-base;version='[2.13.2,2.13.3)',\
com.fasterxml.jackson.jaxrs.jackson-jaxrs-json-provider;version='[2.13.2,2.13.3)',\
com.fasterxml.woodstox.woodstox-core;version='[6.2.7,6.2.8)',\
com.jayway.jsonpath.json-path;version='[2.4.0,2.4.1)',\
io.github.classgraph.classgraph;version='[4.8.95,4.8.96)',\
io.swagger.core.v3.swagger-annotations;version='[2.1.11,2.1.12)',\
io.swagger.core.v3.swagger-core;version='[2.1.11,2.1.12)',\
io.swagger.core.v3.swagger-integration;version='[2.1.11,2.1.12)',\
io.swagger.core.v3.swagger-jaxrs2;version='[2.1.11,2.1.12)',\
io.swagger.core.v3.swagger-models;version='[2.1.11,2.1.12)',\
io.github.classgraph.classgraph;version='[4.8.138,4.8.139)',\
io.swagger.core.v3.swagger-annotations;version='[2.2.0,2.2.1)',\
io.swagger.core.v3.swagger-core;version='[2.2.0,2.2.1)',\
io.swagger.core.v3.swagger-integration;version='[2.2.0,2.2.1)',\
io.swagger.core.v3.swagger-jaxrs2;version='[2.2.0,2.2.1)',\
io.swagger.core.v3.swagger-models;version='[2.2.0,2.2.1)',\
jakarta.validation.jakarta.validation-api;version='[2.0.2,2.0.3)',\
junit-jupiter-api;version='[5.8.2,5.8.3)',\
junit-jupiter-engine;version='[5.8.2,5.8.3)',\
@@ -100,14 +100,14 @@ java.9.plus.reqs: \
org.apache.aries.jax.rs.rest.management;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.rest.management.itest-tests;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.whiteboard;version='[2.0.2,2.0.3)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.4,1.3.5)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.5,1.3.6)',\
org.apache.commons.lang3;version='[3.12.0,3.12.1)',\
org.apache.cxf.cxf-core;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-security;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-core;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-security;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.2,3.5.3)',\
org.apache.felix.configadmin;version='[1.9.24,1.9.25)',\
org.apache.felix.gogo.command;version='[1.1.2,1.1.3)',\
org.apache.felix.gogo.runtime;version='[1.1.4,1.1.5)',\
@@ -132,7 +132,7 @@ java.9.plus.reqs: \
org.osgi.util.promise;version='[1.2.0,1.2.1)',\
org.xmlunit.xmlunit-assertj3;version='[2.9.0,2.9.1)',\
org.xmlunit.xmlunit-core;version='[2.9.0,2.9.1)',\
org.yaml.snakeyaml;version='[1.27.0,1.27.1)',\
org.yaml.snakeyaml;version='[1.30.0,1.30.1)',\
stax2-api;version='[4.2.1,4.2.2)'

blacklist.java.8.jaxb: osgi.identity;filter:='(osgi.identity=jakarta.xml.bind-api)'
@@ -59,13 +59,13 @@ java.9.plus.reqs: \
org.apache.aries.jax.rs.shiro.authz;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.shiro.itest-tests;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.whiteboard;version='[2.0.2,2.0.3)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.4,1.3.5)',\
org.apache.cxf.cxf-core;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-security;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.1,3.5.2)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.5,1.3.6)',\
org.apache.cxf.cxf-core;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-security;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.2,3.5.3)',\
org.apache.felix.configadmin;version='[1.9.24,1.9.25)',\
org.apache.felix.gogo.command;version='[1.1.2,1.1.3)',\
org.apache.felix.gogo.runtime;version='[1.1.4,1.1.5)',\
@@ -60,13 +60,13 @@ java.9.plus.reqs: \
org.apache.aries.component-dsl.component-dsl;version='[1.2.2,1.2.3)',\
org.apache.aries.jax.rs.example;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.whiteboard;version='[2.0.2,2.0.3)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.4,1.3.5)',\
org.apache.cxf.cxf-core;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-security;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.1,3.5.2)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.5,1.3.6)',\
org.apache.cxf.cxf-core;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-security;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.2,3.5.3)',\
org.apache.felix.configadmin;version='[1.9.24,1.9.25)',\
org.apache.felix.gogo.command;version='[1.1.2,1.1.3)',\
org.apache.felix.gogo.runtime;version='[1.1.4,1.1.5)',\
@@ -58,13 +58,13 @@ java.9.plus.reqs: \
com.fasterxml.woodstox.woodstox-core;version='[6.2.7,6.2.8)',\
org.apache.aries.component-dsl.component-dsl;version='[1.2.2,1.2.3)',\
org.apache.aries.jax.rs.whiteboard;version='[2.0.2,2.0.3)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.4,1.3.5)',\
org.apache.cxf.cxf-core;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-security;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.1,3.5.2)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.5,1.3.6)',\
org.apache.cxf.cxf-core;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-security;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.2,3.5.3)',\
org.apache.felix.configadmin;version='[1.9.24,1.9.25)',\
org.apache.felix.http.jetty;version='[4.2.0,4.2.1)',\
org.apache.felix.http.servlet-api;version='[1.2.0,1.2.1)',\
@@ -100,7 +100,6 @@
<artifactId>geronimo-jaxrs_2.1_spec</artifactId>
</dependency>


<!-- This runtime dependency is a Declarative Services implementation,
used to publish the example resource as an OSGi service-->
<dependency>
@@ -61,14 +61,14 @@ java.9.plus.reqs: \
org.apache.aries.component-dsl.component-dsl;version='[1.2.2,1.2.3)',\
org.apache.aries.jax.rs.itests-tests;version='[2.0.2,2.0.3)',\
org.apache.aries.jax.rs.whiteboard;version='[2.0.2,2.0.3)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.4,1.3.5)',\
org.apache.cxf.cxf-core;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-security-cors;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-security;version='[3.5.1,3.5.2)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.1,3.5.2)',\
org.apache.aries.spifly.dynamic.framework.extension;version='[1.3.5,1.3.6)',\
org.apache.cxf.cxf-core;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-frontend-jaxrs;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-client;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-security-cors;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-rs-sse;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-security;version='[3.5.2,3.5.3)',\
org.apache.cxf.cxf-rt-transports-http;version='[3.5.2,3.5.3)',\
org.apache.felix.configadmin;version='[1.9.24,1.9.25)',\
org.apache.felix.gogo.command;version='[1.1.2,1.1.3)',\
org.apache.felix.gogo.runtime;version='[1.1.4,1.1.5)',\
@@ -50,6 +50,10 @@
<groupId>org.apache.geronimo.specs</groupId>
<artifactId>geronimo-annotation_1.3_spec</artifactId>
</dependency>
<dependency>
<groupId>org.osgi</groupId>
<artifactId>org.osgi.namespace.extender</artifactId>
</dependency>
<dependency>
<groupId>org.osgi</groupId>
<artifactId>org.osgi.namespace.implementation</artifactId>
@@ -591,7 +591,7 @@
<goals>
<goal>resolve</goal>
</goals>
<phase>pre-integration-test</phase>
<phase>package</phase>
<configuration>
<reportOptional>false</reportOptional>
<failOnChanges>false</failOnChanges>

0 comments on commit 55fd9fc

Please sign in to comment.