Skip to content
Permalink
Browse files
Merge branch 'gerrit/stabilization-5949a1cb71'
Change-Id: I6d9ed728c40d740cdecde440cadce441ce515798
  • Loading branch information
mblow committed Jan 21, 2022
2 parents 8363dcb + 55e1980 commit 761f0b354a6ecf5be3bee5aaef0167109668d783
Show file tree
Hide file tree
Showing 9 changed files with 129 additions and 75 deletions.
@@ -149,7 +149,6 @@
<dependency>
<groupId>it.unimi.dsi</groupId>
<artifactId>fastutil</artifactId>
<version>8.3.0</version>
</dependency>
<dependency>
<groupId>org.apache.commons</groupId>
@@ -169,32 +169,21 @@
<url>https://raw.githubusercontent.com/mojohaus/appassembler/appassembler-2.0.0/LICENSE.txt</url>
</override>
<override>
<gav>io.netty:netty-transport:4.1.69.Final</gav>
<noticeUrl>https://raw.githubusercontent.com/netty/netty/netty-4.1.69.Final/NOTICE.txt</noticeUrl>
</override>
<override>
<gav>io.netty:netty-codec:4.1.69.Final</gav>
<noticeUrl>https://raw.githubusercontent.com/netty/netty/netty-4.1.69.Final/NOTICE.txt</noticeUrl>
</override>
<override>
<gav>io.netty:netty-buffer:4.1.69.Final</gav>
<noticeUrl>https://raw.githubusercontent.com/netty/netty/netty-4.1.69.Final/NOTICE.txt</noticeUrl>
</override>
<override>
<gav>io.netty:netty-resolver:4.1.69.Final</gav>
<noticeUrl>https://raw.githubusercontent.com/netty/netty/netty-4.1.69.Final/NOTICE.txt</noticeUrl>
</override>
<override>
<gav>io.netty:netty-handler:4.1.69.Final</gav>
<noticeUrl>https://raw.githubusercontent.com/netty/netty/netty-4.1.69.Final/NOTICE.txt</noticeUrl>
</override>
<override>
<gav>io.netty:netty-common:4.1.69.Final</gav>
<gavs>
<gav>io.netty:netty-buffer:4.1.69.Final</gav>
<gav>io.netty:netty-codec:4.1.69.Final</gav>
<gav>io.netty:netty-codec-http:4.1.69.Final</gav>
<gav>io.netty:netty-common:4.1.69.Final</gav>
<gav>io.netty:netty-handler:4.1.69.Final</gav>
<gav>io.netty:netty-resolver:4.1.69.Final</gav>
<gav>io.netty:netty-transport:4.1.69.Final</gav>
</gavs>
<noticeUrl>https://raw.githubusercontent.com/netty/netty/netty-4.1.69.Final/NOTICE.txt</noticeUrl>
</override>
<override>
<gav>io.netty:netty-codec-http:4.1.69.Final</gav>
<noticeUrl>https://raw.githubusercontent.com/netty/netty/netty-4.1.69.Final/NOTICE.txt</noticeUrl>
<gav>io.netty:netty-tcnative-classes:2.0.46.Final</gav>
<url>http://www.apache.org/licenses/LICENSE-2.0</url>
<noticeUrl>https://raw.githubusercontent.com/netty/netty-tcnative/netty-tcnative-parent-2.0.46.Final/NOTICE.txt</noticeUrl>
</override>
<override>
<gav>org.reactivestreams:reactive-streams:1.0.2</gav>
@@ -82,7 +82,7 @@
<hyracks.version>0.3.5-SNAPSHOT</hyracks.version>
<hadoop.version>2.8.5</hadoop.version>
<jacoco.version>0.7.6.201602180812</jacoco.version>
<log4j.version>2.14.1</log4j.version>
<log4j.version>2.17.1</log4j.version>
<awsjavasdk.version>2.10.83</awsjavasdk.version>

<implementation.title>Apache AsterixDB - ${project.name}</implementation.title>
@@ -898,17 +898,17 @@
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-simple</artifactId>
<version>1.7.28</version>
<version>1.7.33</version>
</dependency>
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-plugin-api</artifactId>
<version>3.8.3</version>
<version>3.8.4</version>
</dependency>
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-model</artifactId>
<version>3.8.3</version>
<version>3.8.4</version>
</dependency>
<dependency>
<groupId>org.apache.hadoop</groupId>
@@ -1336,12 +1336,12 @@
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-core</artifactId>
<version>3.8.3</version>
<version>3.8.4</version>
</dependency>
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-compat</artifactId>
<version>3.8.3</version>
<version>3.8.4</version>
</dependency>
<dependency>
<groupId>com.esri.geometry</groupId>
@@ -160,9 +160,9 @@
<artifactId>netty-transport</artifactId>
<properties>
<!-- netty is ALv2, and does not contain any embedded LICENSE or NOTICE file -->
<license.ignoreMissingEmbeddedLicense>4.1.69.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.69.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.69.Final</license.ignoreNoticeOverride>
<license.ignoreMissingEmbeddedLicense>4.1.73.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.73.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.73.Final</license.ignoreNoticeOverride>
</properties>
</project>
</supplement>
@@ -172,9 +172,9 @@
<artifactId>netty-codec</artifactId>
<properties>
<!-- netty is ALv2, and does not contain any embedded LICENSE or NOTICE file -->
<license.ignoreMissingEmbeddedLicense>4.1.69.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.69.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.69.Final</license.ignoreNoticeOverride>
<license.ignoreMissingEmbeddedLicense>4.1.73.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.73.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.73.Final</license.ignoreNoticeOverride>
</properties>
</project>
</supplement>
@@ -184,9 +184,9 @@
<artifactId>netty-handler</artifactId>
<properties>
<!-- netty is ALv2, and does not contain any embedded LICENSE or NOTICE file -->
<license.ignoreMissingEmbeddedLicense>4.1.69.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.69.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.69.Final</license.ignoreNoticeOverride>
<license.ignoreMissingEmbeddedLicense>4.1.73.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.73.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.73.Final</license.ignoreNoticeOverride>
</properties>
</project>
</supplement>
@@ -196,9 +196,9 @@
<artifactId>netty-buffer</artifactId>
<properties>
<!-- netty is ALv2, and does not contain any embedded LICENSE or NOTICE file -->
<license.ignoreMissingEmbeddedLicense>4.1.69.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.69.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.69.Final</license.ignoreNoticeOverride>
<license.ignoreMissingEmbeddedLicense>4.1.73.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.73.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.73.Final</license.ignoreNoticeOverride>
</properties>
</project>
</supplement>
@@ -208,9 +208,9 @@
<artifactId>netty-common</artifactId>
<properties>
<!-- netty is ALv2, and does not contain any embedded LICENSE or NOTICE file -->
<license.ignoreMissingEmbeddedLicense>4.1.69.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.69.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.69.Final</license.ignoreNoticeOverride>
<license.ignoreMissingEmbeddedLicense>4.1.73.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.73.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.73.Final</license.ignoreNoticeOverride>
</properties>
</project>
</supplement>
@@ -220,9 +220,9 @@
<artifactId>netty-codec-http</artifactId>
<properties>
<!-- netty is ALv2, and does not contain any embedded LICENSE or NOTICE file -->
<license.ignoreMissingEmbeddedLicense>4.1.69.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.69.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.69.Final</license.ignoreNoticeOverride>
<license.ignoreMissingEmbeddedLicense>4.1.73.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.73.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.73.Final</license.ignoreNoticeOverride>
</properties>
</project>
</supplement>
@@ -232,9 +232,9 @@
<artifactId>netty-resolver</artifactId>
<properties>
<!-- netty is ALv2, and does not contain any embedded LICENSE or NOTICE file -->
<license.ignoreMissingEmbeddedLicense>4.1.69.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.69.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.69.Final</license.ignoreNoticeOverride>
<license.ignoreMissingEmbeddedLicense>4.1.73.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>4.1.73.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreNoticeOverride>4.1.73.Final</license.ignoreNoticeOverride>
</properties>
</project>
</supplement>
@@ -303,7 +303,7 @@
<artifactId>jackson-annotations</artifactId>
<properties>
<!-- jackson-annotations does not provide an embedded NOTICE file -->
<license.ignoreMissingEmbeddedNotice>2.12.3,2.13.0</license.ignoreMissingEmbeddedNotice>
<license.ignoreMissingEmbeddedNotice>2.12.3,2.13.1</license.ignoreMissingEmbeddedNotice>
</properties>
</project>
</supplement>
@@ -364,9 +364,23 @@
<properties>
<!-- snappy-java is ALv2, and does not contain any embedded LICENSE or NOTICE file -->
<!-- license override not needed, ALv2 is specified in its pom.xml -->
<!-- see https://github.com/xerial/snappy-java/blob/1.1.7.1/LICENSE -->
<license.ignoreMissingEmbeddedLicense>1.1.7.1,1.1.8.4</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>1.1.7.1,1.1.8.4</license.ignoreMissingEmbeddedNotice>
<!-- see https://raw.githubusercontent.com/xerial/snappy-java/1.1.8.4/LICENSE -->
<license.ignoreMissingEmbeddedLicense>1.1.8.4</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>1.1.8.4</license.ignoreMissingEmbeddedNotice>
</properties>
</project>
</supplement>
<supplement>
<project>
<groupId>io.netty</groupId>
<artifactId>netty-tcnative-classes</artifactId>
<properties>
<!-- netty-tcnative-classes is ALv2, and does not contain any embedded LICENSE or NOTICE file -->
<!-- see https://github.com/netty/netty-tcnative/blob/netty-tcnative-parent-2.0.46.Final/LICENSE.txt -->
<license.ignoreMissingEmbeddedLicense>2.0.46.Final</license.ignoreMissingEmbeddedLicense>
<license.ignoreMissingEmbeddedNotice>2.0.46.Final</license.ignoreMissingEmbeddedNotice>
<license.ignoreLicenseOverride>2.0.46.Final</license.ignoreLicenseOverride>
<license.ignoreNoticeOverride>2.0.46.Final</license.ignoreNoticeOverride>
</properties>
</project>
</supplement>
@@ -597,4 +611,5 @@
</project>
</supplement>


</supplementalDataModels>
@@ -0,0 +1,51 @@
The Netty Project
=================

Please visit the Netty web site for more information:

* http://netty.io/

Copyright 2016 The Netty Project

The Netty Project licenses this file to you under the Apache License,
version 2.0 (the "License"); you may not use this file except in compliance
with the License. You may obtain a copy of the License at:

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
License for the specific language governing permissions and limitations
under the License.

-------------------------------------------------------------------------------
This product contains a forked and modified version of Tomcat Native

* LICENSE:
* license/LICENSE.tomcat-native.txt (Apache License 2.0)
* HOMEPAGE:
* http://tomcat.apache.org/native-doc/
* https://svn.apache.org/repos/asf/tomcat/native/

This product contains the Maven wrapper scripts from 'Maven Wrapper', that provides an easy way to ensure a user has everything necessary to run the Maven build.

* LICENSE:
* license/LICENSE.mvn-wrapper.txt (Apache License 2.0)
* HOMEPAGE:
* https://github.com/takari/maven-wrapper

This product contains small piece of code to support AIX, taken from netbsd.

* LICENSE:
* license/LICENSE.aix-netbsd.txt (OpenSSL License)
* HOMEPAGE:
* https://ftp.netbsd.org/pub/NetBSD/NetBSD-current/src/crypto/external/bsd/openssl/dist


This product contains code from boringssl.

* LICENSE (Combination ISC and OpenSSL license)
* license/LICENSE.boringssl.txt (Combination ISC and OpenSSL license)
* HOMEPAGE:
* https://boringssl.googlesource.com/boringssl/
@@ -82,7 +82,7 @@
<dependency>
<groupId>org.apache.httpcomponents</groupId>
<artifactId>httpcore-nio</artifactId>
<version>4.4.10</version>
<version>4.4.15</version>
<scope>test</scope>
</dependency>
<dependency>
@@ -54,7 +54,7 @@
<dependency>
<groupId>org.freemarker</groupId>
<artifactId>freemarker</artifactId>
<version>2.3.29</version>
<version>2.3.31</version>
</dependency>
<dependency>
<groupId>commons-io</groupId>

0 comments on commit 761f0b3

Please sign in to comment.