Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
Browse files
Upgrading npm dependencies with ciritical vulnerabililities (#103)
* Upgrading two npm packages which contained critical vulnerabilities.

* Upgrading webpack. 

* Setting ajv-keywords and ajv versions for version resolution. 

* Adding required webpack-cli to dependencies as its required by the latest version of webpack. 

* Pinning node version to be the latest LTS.
  • Loading branch information
ridv committed Jan 13, 2020
1 parent 17329fc commit a888fb755fa7837d1b78e6a403f2b82ebbc7a9e2
Showing 2 changed files with 6 additions and 2 deletions.
@@ -139,6 +139,7 @@ project(':ui') {
apply plugin: 'com.moowork.node'
node {
download = true
version = '12.14.1'
}

task test_(type: NpmTask, overwrite: true) {
@@ -15,6 +15,8 @@
"react-router-dom": "^4.2.2"
},
"devDependencies": {
"ajv": "^6.10.2",
"ajv-keywords": "^3.4.1",
"babel-core": "^6.26.0",
"babel-eslint": "^7.2.3",
"babel-jest": "^21.2.0",
@@ -23,7 +25,7 @@
"babel-plugin-transform-react-jsx": "^6.24.1",
"babel-preset-es2015": "^6.24.1",
"babel-preset-react": "^6.24.1",
"css-loader": "^0.28.5",
"css-loader": "^3.4.1",
"enzyme": "^3.0.0",
"enzyme-adapter-react-16": "^1.0.0",
"eslint": "^4.4.1",
@@ -43,7 +45,8 @@
"sassjs-loader": "^1.0.0",
"style-loader": "^0.18.2",
"url-loader": "^0.6.2",
"webpack": "^2.6.1"
"webpack": "^4.41.5",
"webpack-cli": "^3.3.10"
},
"jest": {
"moduleDirectories": [

0 comments on commit a888fb7

Please sign in to comment.