Skip to content
Permalink
Browse files
BIGTOP-3569. Applying GPDB Puppet manifest fails on arm64. (#797)
  • Loading branch information
sekikn committed Jul 10, 2021
1 parent 8c353ad commit afa9c60f22167357f63eaa8ceaaed90913ce88f8
Show file tree
Hide file tree
Showing 3 changed files with 3 additions and 3 deletions.
@@ -111,7 +111,7 @@
# GPDB requires the following python packages as of v5.28.5. See
# https://github.com/greenplum-db/gpdb/tree/5X_STABLE#building-greenplum-database-with-gporca.
exec { 'install_python_packages':
command => '/usr/bin/env pip install -q lockfile paramiko psutil',
command => "/usr/bin/env pip install -q 'cryptography<3.3' lockfile paramiko psutil",
require => [Exec["install_pip"]],
}
package { ["gpdb"]:
@@ -22,6 +22,6 @@ Homepage: https://github.com/greenplum-db/gpdb

Package: gpdb
Architecture: any
Depends: ${shlibs:Depends}, python (>= 2.6), python (<< 3)
Depends: ${shlibs:Depends}, bigtop-utils (>= 0.7), gcc, libffi-dev, libssl-dev, make, python-dev (>= 2.6), python-dev (<< 3)
Description: Greenplum MPP database engine
Provides the Greenplum MPP database engine
@@ -39,7 +39,7 @@ Source2: install_gpdb.sh
Source3: do-component-configure
#BIGTOP_PATCH_FILES
AutoReqProv: %{autorequire}
Requires: python2
Requires: bigtop-utils >= 0.7, gcc, libffi-devel, make, openssl-devel, python2-devel

%description
gpdb

0 comments on commit afa9c60

Please sign in to comment.