Skip to content
Permalink
Browse files
Update to Django 4 and minimum python 3.8
  • Loading branch information
Gary Martin committed Mar 14, 2022
1 parent 31087bb commit a3c95e3258c6561dd3e4e6d483170eb869680ab6
Show file tree
Hide file tree
Showing 2 changed files with 7 additions and 6 deletions.
@@ -27,7 +27,7 @@ This version of Apache Bloodhound requires Python, Poetry and Django.

### Installing Python

The versions of Python that can be used are currently 3.6, 3.7, 3.8 and 3.9.
The versions of Python that can be used are currently 3.8, 3.9 and 3.10.

Where convenient is it sensible to go for the newest release of Python that
you can.
@@ -6,12 +6,13 @@ authors = ["Apache Bloodhound <dev@bloodhound.apache.org>"]
license = "Apache-2.0"

[tool.poetry.dependencies]
python = "^3.6"
django = "^3.2.2"
django-rest-framework = "^0.1.0"
python = "^3.8"
Django = "^4.0.3"
djangorestframework = "^3.13.1"
Markdown = "^3.3.6"
drf-yasg = "^1.20.0"
drf-nested-routers = "^0.93.3"
pyyaml = "^5.4.1"
drf-nested-routers = "^0.93.4"
PyYAML = "^6.0"
psycopg2 = { version = "^2.9", optional = true }
psycopg2-binary = { version = "^2.9", optional = true }

0 comments on commit a3c95e3

Please sign in to comment.