Skip to content
Permalink
Browse files
[security] Bump bc fips version from 1.0.2.1 to 1.0.2.3 (#3087)
  • Loading branch information
Shoothzj committed Apr 2, 2022
1 parent bf2765a commit 28e47f9f2a94a7e451e1459b9d9de5296862554f
Showing 12 changed files with 14 additions and 14 deletions.
@@ -58,7 +58,7 @@ def depLicences = [
"checker-qual-3.5.0/LICENSE",
"google-auth-library-credentials-0.20.0/LICENSE",
"javax.servlet-api-4.0.0/CDDL+GPL-1.1",
"bouncycastle-1.0.2.1/LICENSE.html",
"bouncycastle-1.0.2.3/LICENSE.html",
"jsr-305/LICENSE",
"netty-4.1.74.Final/*",
"paranamer-2.8/LICENSE.txt",
@@ -50,7 +50,7 @@ def depLicences = [
"checker-qual-3.5.0/LICENSE",
"google-auth-library-credentials-0.20.0/LICENSE",
"netty-4.1.74.Final/*",
"bouncycastle-1.0.2.1/LICENSE.html",
"bouncycastle-1.0.2.3/LICENSE.html",
"protobuf-3.14.0/LICENSE",
"protobuf-3.12.0/LICENSE",
"reactivestreams-1.0.3/LICENSE",
@@ -54,7 +54,7 @@ def depLicences = [
"google-auth-library-credentials-0.20.0/LICENSE",
"javax.servlet-api-4.0.0/CDDL+GPL-1.1",
"netty-4.1.74.Final/*",
"bouncycastle-1.0.2.1/LICENSE.html",
"bouncycastle-1.0.2.3/LICENSE.html",
"protobuf-3.14.0/LICENSE",
"protobuf-3.12.0/LICENSE",
"reactivestreams-1.0.3/LICENSE",
@@ -57,7 +57,7 @@
<include>checker-qual-3.5.0/LICENSE</include>
<include>google-auth-library-credentials-0.20.0/LICENSE</include>
<include>javax.servlet-api-4.0.0/CDDL+GPL-1.1</include>
<include>bouncycastle-1.0.2.1/LICENSE.html</include>
<include>bouncycastle-1.0.2.3/LICENSE.html</include>
<include>jsr-305/LICENSE</include>
<include>netty-4.1.74.Final/*</include>
<include>paranamer-2.8/LICENSE.txt</include>
@@ -53,7 +53,7 @@
<include>google-auth-library-credentials-0.20.0/LICENSE</include>
<include>javax.servlet-api-4.0.0/CDDL+GPL-1.1</include>
<include>netty-4.1.74.Final/*</include>
<include>bouncycastle-1.0.2.1/LICENSE.html</include>
<include>bouncycastle-1.0.2.3/LICENSE.html</include>
<include>protobuf-3.14.0/LICENSE</include>
<include>protobuf-3.12.0/LICENSE</include>
<include>reactivestreams-1.0.3/LICENSE</include>
@@ -70,7 +70,7 @@
<include>checker-qual-3.5.0/LICENSE</include>
<include>google-auth-library-credentials-0.20.0/LICENSE</include>
<include>netty-4.1.74.Final/*</include>
<include>bouncycastle-1.0.2.1/LICENSE.html</include>
<include>bouncycastle-1.0.2.3/LICENSE.html</include>
<include>protobuf-3.14.0/LICENSE</include>
<include>protobuf-3.12.0/LICENSE</include>
<include>reactivestreams-1.0.3/LICENSE</include>
@@ -658,10 +658,10 @@ Bundled as
Source available at https://github.com/googleapis/google-auth-library-java/releases/tag/v0.22.2
------------------------------------------------------------------------------------
This product bundles the bouncycastle Library.
For license details, see deps/bouncycastle-1.0.2.1/LICENSE.html
For license details, see deps/bouncycastle-1.0.2.3/LICENSE.html

Bundled as
- lib/org.bouncycastle-bc-fips-1.0.2.1.jar
- lib/org.bouncycastle-bc-fips-1.0.2.3.jar
------------------------------------------------------------------------------------
This product uses the annotations from The Checker Framework, which are licensed under
MIT License. For details, see deps/checker-qual-3.5.0/LICENSE
@@ -584,10 +584,10 @@ Bundled as
Source available at https://github.com/google/google-auth-library-java/tree/0.22.2
------------------------------------------------------------------------------------
This product bundles the bouncycastle Library.
For license details, see deps/bouncycastle-1.0.2.1/LICENSE.html
For license details, see deps/bouncycastle-1.0.2.3/LICENSE.html

Bundled as
- lib/org.bouncycastle-bc-fips-1.0.2.1.jar
- lib/org.bouncycastle-bc-fips-1.0.2.3.jar
------------------------------------------------------------------------------------

This product uses the annotations from The Checker Framework, which are licensed under
@@ -650,10 +650,10 @@ Bundled as
Source available at https://github.com/googleapis/google-auth-library-java/releases/tag/v0.22.2
------------------------------------------------------------------------------------
This product bundles the bouncycastle Library.
For license details, see deps/bouncycastle-1.0.2.1/LICENSE.html
For license details, see deps/bouncycastle-1.0.2.3/LICENSE.html

Bundled as
- lib/org.bouncycastle-bc-fips-1.0.2.1.jar
- lib/org.bouncycastle-bc-fips-1.0.2.3.jar
------------------------------------------------------------------------------------
This product uses the annotations from The Checker Framework, which are licensed under
MIT License. For details, see deps/checker-qual-3.5.0/LICENSE
@@ -24,7 +24,7 @@ ext {
depVersions = [
arquillianCubeDocker: "1.18.2",
arquillianJunit: "1.6.0.Final",
bcFips: "1.0.2.1",
bcFips: "1.0.2.3",
bouncycastle: "1.69",
commonsCli: "1.2",
commonsCodec: "1.6",
@@ -123,7 +123,7 @@
<commons-lang.version>2.6</commons-lang.version>
<commons-lang3.version>3.6</commons-lang3.version>
<commons-io.version>2.7</commons-io.version>
<bouncycastle.version>1.0.2.1</bouncycastle.version>
<bouncycastle.version>1.0.2.3</bouncycastle.version>
<curator.version>5.1.0</curator.version>
<dropwizard.version>3.2.5</dropwizard.version>
<etcd.version>0.5.11</etcd.version>

0 comments on commit 28e47f9

Please sign in to comment.