Skip to content
Permalink
Browse files
Change GO386 depending on go version available
  • Loading branch information
jcabrerizo committed Sep 8, 2021
1 parent e1fc90e commit 53eacb5882726c3e20cefd199fae7c27c0de320b
Showing 1 changed file with 13 additions and 0 deletions.
@@ -184,6 +184,19 @@ See golang.org for more information, or run maven with '-Dno-go-client' to skip.
exit 1
fi
if !(( "$GO_V" >= 16 )) ; then
export GO386=387
echo "Updated GO386=$GO386 due GO version compatibilityq"
cat 1>&2 << \
--MARKER--
ERROR: Incompatible Go language version: $GO_VERSION
Go version 1.16 doesn't support GO386=387
--MARKER--
fi
mkdir -p $outdir
# Disable use of C code modules (causes problems with cross-compiling)

0 comments on commit 53eacb5

Please sign in to comment.