Skip to content
Permalink
Browse files
updating to latest ruby - 3.0.1 - ruby installs but doesn't yet run
will fix ruby running shortly
  • Loading branch information
ahgittin committed May 20, 2021
1 parent f8243c7 commit f2f2f612c7d41a53288007bc4bcac2fbfa18b66b
Show file tree
Hide file tree
Showing 4 changed files with 91 additions and 84 deletions.
@@ -42,3 +42,5 @@ _book
node_modules
javadoc/stylesheet.css
javadoc/javadoc.log

.jekyll-cache
@@ -1,8 +1,8 @@
#ruby=ruby-2.1.2
#ruby=ruby-3.0.1
#ruby-gemset=brooklyn-site

source 'https://rubygems.org'
ruby '2.1.2'
ruby '3.0.1'

gem 'jekyll'
gem 'therubyracer'
@@ -1,98 +1,99 @@
GEM
remote: https://rubygems.org/
specs:
addressable (2.3.6)
blankslate (2.1.2.4)
celluloid (0.16.0)
timers (~> 4.0.0)
classifier-reborn (2.0.3)
fast-stemmer (~> 1.0)
coffee-script (2.3.0)
coffee-script-source
execjs
coffee-script-source (1.8.0)
colorator (0.1)
colored (1.2)
ethon (0.7.2)
ffi (>= 1.3.0)
execjs (2.2.2)
fast-stemmer (1.0.2)
ffi (1.9.6)
hitimes (1.2.2)
html-proofer (1.6.0)
addressable (2.7.0)
public_suffix (>= 2.0.2, < 5.0)
colorator (1.1.0)
concurrent-ruby (1.1.8)
em-websocket (0.5.2)
eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0)
ethon (0.14.0)
ffi (>= 1.15.0)
eventmachine (1.2.7)
ffi (1.15.0)
forwardable-extended (2.6.0)
html-proofer (3.19.1)
addressable (~> 2.3)
colored (~> 1.2)
mercenary (~> 0.3.2)
nokogiri (~> 1.5)
mercenary (~> 0.3)
nokogumbo (~> 2.0)
parallel (~> 1.3)
typhoeus (~> 0.6.7)
rainbow (~> 3.0)
typhoeus (~> 1.3)
yell (~> 2.0)
jekyll (2.5.3)
classifier-reborn (~> 2.0)
colorator (~> 0.1)
jekyll-coffeescript (~> 1.0)
jekyll-gist (~> 1.0)
jekyll-paginate (~> 1.0)
jekyll-sass-converter (~> 1.0)
jekyll-watch (~> 1.1)
kramdown (~> 1.3)
liquid (~> 2.6.1)
mercenary (~> 0.3.3)
pygments.rb (~> 0.6.0)
redcarpet (~> 3.1)
http_parser.rb (0.6.0)
i18n (1.8.10)
concurrent-ruby (~> 1.0)
jekyll (4.2.0)
addressable (~> 2.4)
colorator (~> 1.0)
em-websocket (~> 0.5)
i18n (~> 1.0)
jekyll-sass-converter (~> 2.0)
jekyll-watch (~> 2.0)
kramdown (~> 2.3)
kramdown-parser-gfm (~> 1.0)
liquid (~> 4.0)
mercenary (~> 0.4.0)
pathutil (~> 0.9)
rouge (~> 3.0)
safe_yaml (~> 1.0)
toml (~> 0.1.0)
jekyll-coffeescript (1.0.1)
coffee-script (~> 2.2)
jekyll-gist (1.1.0)
jekyll-paginate (1.1.0)
jekyll-sass-converter (1.3.0)
sass (~> 3.2)
jekyll-watch (1.2.0)
listen (~> 2.7)
json (1.8.2)
kramdown (1.5.0)
libv8 (3.16.14.7)
liquid (2.6.1)
listen (2.8.5)
celluloid (>= 0.15.2)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9)
mercenary (0.3.5)
mini_portile (0.6.2)
nokogiri (1.6.5)
mini_portile (~> 0.6.0)
parallel (1.3.3)
parslet (1.5.0)
blankslate (~> 2.0)
posix-spawn (0.3.9)
pygments.rb (0.6.0)
posix-spawn (~> 0.3.6)
yajl-ruby (~> 1.1.0)
rb-fsevent (0.9.4)
rb-inotify (0.9.5)
ffi (>= 0.5.0)
redcarpet (3.2.2)
ref (1.0.5)
safe_yaml (1.0.4)
sass (3.4.9)
therubyracer (0.12.1)
libv8 (~> 3.16.14.0)
terminal-table (~> 2.0)
jekyll-sass-converter (2.1.0)
sassc (> 2.0.1, < 3.0)
jekyll-watch (2.2.1)
listen (~> 3.0)
json (2.5.1)
kramdown (2.3.1)
rexml
kramdown-parser-gfm (1.1.0)
kramdown (~> 2.0)
libv8 (3.16.14.19)
liquid (4.0.3)
listen (3.5.1)
rb-fsevent (~> 0.10, >= 0.10.3)
rb-inotify (~> 0.9, >= 0.9.10)
mercenary (0.4.0)
nokogiri (1.11.5-x86_64-darwin)
racc (~> 1.4)
nokogumbo (2.0.5)
nokogiri (~> 1.8, >= 1.8.4)
parallel (1.20.1)
pathutil (0.16.2)
forwardable-extended (~> 2.6)
public_suffix (4.0.6)
racc (1.5.2)
rainbow (3.0.0)
rb-fsevent (0.11.0)
rb-inotify (0.10.1)
ffi (~> 1.0)
ref (2.0.0)
rexml (3.2.5)
rouge (3.26.0)
safe_yaml (1.0.5)
sassc (2.4.0)
ffi (~> 1.9)
terminal-table (2.0.0)
unicode-display_width (~> 1.1, >= 1.1.1)
therubyracer (0.12.3)
libv8 (~> 3.16.14.15)
ref
timers (4.0.1)
hitimes
toml (0.1.2)
parslet (~> 1.5.0)
typhoeus (0.6.9)
ethon (>= 0.7.1)
yajl-ruby (1.1.0)
yell (2.0.5)
typhoeus (1.4.0)
ethon (>= 0.9.0)
unicode-display_width (1.7.0)
yell (2.2.2)

PLATFORMS
ruby
x86_64-darwin-20

DEPENDENCIES
html-proofer
jekyll
json
therubyracer

RUBY VERSION
ruby 3.0.1p64

BUNDLED WITH
2.2.15
@@ -62,6 +62,10 @@ Some issues we've encountered are:
* if `libxml2` fails, set `bundle config build.nokogiri --use-system-libraries` before the install
(more details [here](http://www.nokogiri.org/tutorials/installing_nokogiri.html))
* on Ubuntu, `sudo apt-get install libxslt-dev libxml2-dev libcurl4-openssl-dev python-minimal`
* if openssl library headers are not found, set the dir explicitly, eg for `eventmachine` try `gem install eventmachine -- --with-openssl-dir=/usr/local/opt/openssl@1.1`
* if `libv8` complains: `gem install libv8 -- --with-system-v8` or eg `gem install libv8 -v '3.16.14.19' -- --with-system-v8`
* for rubyracer to find v8: `gem install therubyracer -- --with-v8-dir=/usr/local/opt/v8@3.15`


If you are building the PDF documentation, this requires [wkhtmltopdf](http://wkhtmltopdf.org/).
You can download it from [here](http://wkhtmltopdf.org/downloads.html) or use the usual apt-get / yum / brew.

0 comments on commit f2f2f61

Please sign in to comment.