Skip to content
Permalink
Browse files
Merge remote-tracking branch 'apache/0.12.0'
  • Loading branch information
rdowner committed Oct 16, 2017
2 parents 3ebb1e6 + 31d3b9f commit fa1077f541947c57e265e58b72940e785ed7791f
Show file tree
Hide file tree
Showing 8 changed files with 157 additions and 23 deletions.
@@ -45,13 +45,13 @@ exclude: ['/Gemfile*','/README.md']
sass:
sass_dir: style/css

# TODO the 0.11.0 paths must be changed!
brooklyn-stable-version: 0.11.0
# TODO the 0.12.0 paths must be changed!
brooklyn-stable-version: 0.12.0
pdf-default-base-url: http://brooklyn.apache.org
pdf-default-versioned-url-subpath: /v/0.11.0
pdf-default-versioned-url-subpath: /v/0.12.0

pdf-rewrite-prefixes:
'/guide' : '/v/0.11.0'
'/guide' : '/v/0.12.0'
'/website' : ''

brooklyn-version: 1.0.0-SNAPSHOT # BROOKLYN_VERSION
@@ -40,10 +40,10 @@ The latest stable release can be accessed on the [main download page]({{ site.pa
</tr>
<tr>
<td style='text-align:left;vertical-align:top'>DEB package<br />Ubuntu, Debian, etc.</td>
<td style='text-align:left'><a href='{{ site.brooklyn.download_prefix }}.all.deb' title='Download DEB package'>apache-brooklyn-{{ site.brooklyn-version }}.all.deb</a></td>
<td style='text-align:left'><a href='{{ site.brooklyn.download_prefix }}.deb' title='Download DEB package'>apache-brooklyn-{{ site.brooklyn-version }}.deb</a></td>
<td><small>
{% if site.brooklyn.is_release %}<a href='{{ site.brooklyn.hash_download_prefix }}.all.deb.asc'>PGP</a>, {% endif %}
<a href='{{ site.brooklyn.hash_download_prefix }}.all.deb.sha1'>SHA1</a></small></td>
{% if site.brooklyn.is_release %}<a href='{{ site.brooklyn.hash_download_prefix }}.deb.asc'>PGP</a>, {% endif %}
<a href='{{ site.brooklyn.hash_download_prefix }}.deb.sha1'>SHA1</a></small></td>
</tr>
<tr>
<td style='text-align:left;vertical-align:top' rowspan='6'>Client CLI only</td>
@@ -50,7 +50,7 @@ Instead, code must be built and installed as [OSGi bundles](https://en.wikipedia
sudo yum upgrade apache-brooklyn-xxxx.noarch.rpm

# Ubuntu / Debian
sudo dpkg -i apache-brooklyn-xxxx.all.deb
sudo dpkg -i apache-brooklyn-xxxx.deb

If there are conflicts in configuration files (located in `/etc/brooklyn`), the upgrade will behave differently based
on the package you are using:
@@ -198,7 +198,7 @@ Instead, code must be built and installed as [OSGi bundles](https://en.wikipedia
sudo yum install apache-brooklyn-xxxx.noarch.rpm

# Ubuntu / Debian
sudo dpkg -i apache-brooklyn-xxxx.all.deb
sudo dpkg -i apache-brooklyn-xxxx.deb

6. Restore the persisted state and configuration.

@@ -286,7 +286,7 @@ This section applies only with you are using the RPM/DEB packages. To perform a
yum downgrade apache-brooklyn.noarch

# Ubuntu Debian
dpkg -i apache-brooklyn-xxxx.all.deb
dpkg -i apache-brooklyn-xxxx.deb
{% endhighlight %}

*Note that to downgrade a DEB package is essentially installing a previous version therefore you need to [download](../misc/download.html)
@@ -105,16 +105,7 @@
});


<!-- analytics -->
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-30530918-1']);
_gaq.push(['_trackPageview']);

(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();

<!-- page warning (for archive pages) -->
if (document.location.pathname.indexOf('guide/') > -1) {
@@ -164,4 +155,15 @@
$('#page_notes').fadeIn('slow');
event.preventDefault ? event.preventDefault() : event.returnValue = false;
}
})(jQuery, ZeroClipboard);
})(jQuery, ZeroClipboard);

<!-- analytics -->
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-107990351-1']);
_gaq.push(['_trackPageview']);

(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
@@ -11,10 +11,10 @@ releases. To allow these example commands to run unmodified, set these environme
# The version currently set on the master branch (BROOKLYN_VERSION_BELOW)
OLD_MASTER_VERSION=1.0.0-SNAPSHOT
# The next version to be set on the master branch
NEW_MASTER_VERSION=0.10.0-SNAPSHOT
NEW_MASTER_VERSION=1.1.0-SNAPSHOT

# The version we are releasing now.
VERSION_NAME=0.9.0
VERSION_NAME=1.0.0

# The release candidate number we are making now.
RC_NUMBER=1
@@ -43,7 +43,7 @@ Suitable Ubuntu and Debian distributions.
</div>

<div class="text-center">
<a class="btn btn-default" href="https://www.apache.org/dyn/closer.lua?action=download&filename=brooklyn/apache-brooklyn-{{ site.brooklyn-stable-version }}/apache-brooklyn-{{ site.brooklyn-stable-version }}.all.deb" role="button">DEB package</a>
<a class="btn btn-default" href="https://www.apache.org/dyn/closer.lua?action=download&filename=brooklyn/apache-brooklyn-{{ site.brooklyn-stable-version }}/apache-brooklyn-{{ site.brooklyn-stable-version }}.deb" role="button">DEB package</a>
</div>
</div>
</div>
@@ -17,6 +17,84 @@ so there is already reduced opportunity for anyone maliciously tampering with th
<th colspan="3">Hashes</th>
</tr>

<tr>
<td>apache-brooklyn-0.12.0-bin.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-bin.tar.gz.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-bin.tar.gz.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-bin.tar.gz.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-bin.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-bin.zip.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-bin.zip.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-bin.zip.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-classic.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-classic.tar.gz.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-classic.tar.gz.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-classic.tar.gz.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-classic.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-classic.zip.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-classic.zip.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-classic.zip.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-1.noarch.rpm</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-1.noarch.rpm.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-1.noarch.rpm.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-1.noarch.rpm.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-src.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-src.tar.gz.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-src.tar.gz.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-src.tar.gz.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-src.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-src.zip.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-src.zip.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-src.zip.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-linux.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-linux.tar.gz.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-linux.tar.gz.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-linux.tar.gz.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-linux.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-linux.zip.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-linux.zip.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-linux.zip.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-macosx.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-macosx.tar.gz.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-macosx.tar.gz.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-macosx.tar.gz.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-macosx.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-macosx.zip.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-macosx.zip.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-macosx.zip.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-windows.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-windows.tar.gz.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-windows.tar.gz.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-windows.tar.gz.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-windows.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-windows.zip.md5">md5</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-windows.zip.sha1">sha1</a></td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-windows.zip.sha256">sha256</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.11.0-bin.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.11.0/apache-brooklyn-0.11.0-bin.tar.gz.md5">md5</a></td>
@@ -325,6 +403,58 @@ Software Foundation mirrors so there will be reduced opportunity for tampering w
<td><a href="https://www.apache.org/dist/brooklyn/KEYS">KEYS</a></td>
</tr>

<tr>
<td>apache-brooklyn-0.12.0-bin.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-bin.tar.gz.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-bin.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-bin.zip.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-classic.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-classic.tar.gz.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-classic.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-classic.zip.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-1.noarch.rpm</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-1.noarch.rpm.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-src.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-src.tar.gz.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-src.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-src.zip.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-linux.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-linux.tar.gz.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-linux.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-linux.zip.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-macosx.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-macosx.tar.gz.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-macosx.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-macosx.zip.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-windows.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-windows.tar.gz.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.12.0-client-cli-windows.zip</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.12.0/apache-brooklyn-0.12.0-client-cli-windows.zip.asc">asc</a></td>
</tr>
<tr>
<td>apache-brooklyn-0.11.0-bin.tar.gz</td>
<td><a href="https://www.apache.org/dist/brooklyn/apache-brooklyn-0.11.0/apache-brooklyn-0.11.0-bin.tar.gz.asc">asc</a></td>
@@ -19,6 +19,8 @@ This documentation was generated {{ site.time | date_to_string }}.

Apache Brooklyn has made the following releases:

* **[0.12.0](/v/0.12.0/)**: OSGI container runtime, improved catalog and bundle integration (September 2017)

* **[0.11.0](/v/0.11.0/)**: Improved cloud support, additional blueprinting features (May 2017)

* **[0.10.0](/v/0.10.0/)**: Improved blueprints and CLI, new DSL features,

0 comments on commit fa1077f

Please sign in to comment.