Skip to content
Permalink
Browse files
Upgrade Quarkus to 2.9.0.CR1
  • Loading branch information
jamesnetherton committed Apr 28, 2022
1 parent 7288ad8 commit 2eb971e8c7ba13c0cf3d31ac43a23c8cfbaf4eaa
Showing 8 changed files with 26 additions and 18 deletions.
@@ -31,7 +31,7 @@ asciidoc:
target-maven-version: 3.8.4 # replace ${target-maven-version}
camel-version: 3.16.0 # replace ${camel.version}
camel-docs-version: 3.16.x # replace ${camel.docs.components.version}
quarkus-version: 2.8.0.Final # replace ${quarkus.version}
quarkus-version: 2.9.0.CR1 # replace ${quarkus.version}
graalvm-version: 22.0.0.2 # replace ${graalvm.version}
graalvm-docs-version: 22.0
# attributes used in xrefs to other Antora components
@@ -23,6 +23,7 @@
import org.apache.camel.component.kafka.KafkaConfiguration;
import org.apache.kafka.clients.CommonClientConfigs;
import org.apache.kafka.clients.consumer.Consumer;
import org.apache.kafka.clients.consumer.ConsumerConfig;
import org.apache.kafka.clients.producer.Producer;

/**
@@ -63,6 +64,11 @@ public String getBrokers(KafkaConfiguration configuration) {
public void mergeConfiguration(Properties camelKafkaProperties) {
if (quarkusKafkaConfiguration != null) {
for (Map.Entry<String, Object> entry : quarkusKafkaConfiguration.entrySet()) {
// Don't overwrite the group id if it has been set
if (entry.getKey().equals(ConsumerConfig.GROUP_ID_CONFIG)
&& camelKafkaProperties.containsKey(ConsumerConfig.GROUP_ID_CONFIG)) {
continue;
}
camelKafkaProperties.put(entry.getKey(), entry.getValue());
}
}
@@ -86,6 +86,7 @@ public static Asset applicationProperties() {
Properties props = new Properties();
props.setProperty("quarkus.log.file.enable", "true");
props.setProperty("quarkus.log.file.path", LOG_FILE.toString());
props.setProperty("quarkus.log.file.rotation.rotate-on-boot", "false");
try {
props.store(writer, "");
} catch (IOException e) {
@@ -24,6 +24,7 @@
import org.junit.jupiter.api.Test;

import static org.hamcrest.Matchers.contains;
import static org.hamcrest.Matchers.containsInAnyOrder;
import static org.hamcrest.Matchers.is;

@QuarkusTest
@@ -48,7 +49,7 @@ public void testJpaComponent() {
RestAssured.get("/jpa/get")
.then()
.statusCode(200)
.body("name", contains(fruits));
.body("name", containsInAnyOrder(fruits));

// Retrieve with entity id as body
RestAssured.get("/jpa/get/1")
@@ -56,7 +56,7 @@
<quarkiverse-minio.version>2.3.0</quarkiverse-minio.version><!-- https://repo1.maven.org/maven2/io/quarkiverse/minio/quarkus-minio-parent/ -->
<quarkiverse-mybatis.version>1.0.2</quarkiverse-mybatis.version><!-- https://repo1.maven.org/maven2/io/quarkiverse/mybatis/quarkus-mybatis-parent/ -->
<quarkiverse-tika.version>1.0.3</quarkiverse-tika.version><!-- https://repo1.maven.org/maven2/io/quarkiverse/tika/quarkus-tika-parent/ -->
<quarkus.version>2.8.0.Final</quarkus.version><!-- https://repo1.maven.org/maven2/io/quarkus/quarkus-bom/ -->
<quarkus.version>2.9.0.CR1</quarkus.version><!-- https://repo1.maven.org/maven2/io/quarkus/quarkus-bom/ -->
<quarkus-hazelcast-client.version>3.0.0</quarkus-hazelcast-client.version><!-- https://repo1.maven.org/maven2/com/hazelcast/quarkus-hazelcast-client-bom/ -->
<quarkus-qpid-jms.version>0.33.0</quarkus-qpid-jms.version><!-- https://repo1.maven.org/maven2/org/amqphub/quarkus/quarkus-qpid-jms-bom/ -->

@@ -89,14 +89,14 @@
<google-native-image-support.version>0.8.0</google-native-image-support.version>
<google-auth-library-credentials.version>${grpc-google-auth-library-version}</google-auth-library-credentials.version>
<graalvm.version>22.0.0.2</graalvm.version><!-- @sync io.quarkus:quarkus-bom:${quarkus.version} dep:org.graalvm.nativeimage:svm -->
<grpc.version>1.45.0</grpc.version><!-- @sync io.quarkus:quarkus-bom:${quarkus.version} dep:io.grpc:grpc-core -->
<grpc.version>1.45.1</grpc.version><!-- @sync io.quarkus:quarkus-bom:${quarkus.version} dep:io.grpc:grpc-core -->
<guice-servlet.version>4.0</guice-servlet.version><!-- Spark -->
<hadoop3.version>${hadoop3-version}</hadoop3.version><!-- Spark -->
<hapi.version>${hapi-version}</hapi.version>
<hapi-fhir.version>${hapi-fhir-version}</hapi-fhir.version>
<hbase.version>${hbase-version}</hbase.version>
<htrace.version>4.2.0-incubating</htrace.version><!-- Mess in hbase transitive deps -->
<infinispan.version>13.0.6.Final</infinispan.version><!-- @sync io.quarkus:quarkus-bom:${quarkus.version} dep:org.infinispan:infinispan-core -->
<infinispan.version>13.0.8.Final</infinispan.version><!-- @sync io.quarkus:quarkus-bom:${quarkus.version} dep:org.infinispan:infinispan-core -->
<influxdb.version>${influx-java-driver-version}</influxdb.version>
<jackson1.version>1.9.13</jackson1.version><!-- Mess in the transitive dependencies of spark and hbase-testing-util -->
<jackson-asl.version>${jackson1.version}</jackson-asl.version><!-- Can be different from jackson1.version on some occasions -->
@@ -117,7 +117,7 @@
<jzlib.version>1.1.3</jzlib.version><!-- @sync io.quarkiverse.jsch:quarkus-jsch-parent:${quarkiverse-jsch.version} prop:jzlib.version -->
<kafka.version>3.1.0</kafka.version><!-- @sync io.quarkus:quarkus-bom:${quarkus.version} dep:org.apache.kafka:kafka-clients -->
<kudu.version>${kudu-version}</kudu.version>
<kotlin.version>1.6.10</kotlin.version><!-- @sync io.quarkus:quarkus-bom:${quarkus.version} dep:org.jetbrains.kotlin:kotlin-stdlib -->
<kotlin.version>1.6.21</kotlin.version><!-- @sync io.quarkus:quarkus-bom:${quarkus.version} dep:org.jetbrains.kotlin:kotlin-stdlib -->
<libthrift.version>${libthrift-version}</libthrift.version> <!-- Spark -->
<metrics.version>${metrics-version}</metrics.version><!-- Spark -->
<mvel2.version>2.4.13.Final</mvel2.version><!-- @sync org.apache.camel:camel-dependencies:${camel.version} prop:mvel-version -->
@@ -10097,7 +10097,7 @@
<dependency>
<groupId>org.infinispan</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<artifactId>infinispan-jboss-marshalling</artifactId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>13.0.6.Final</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>13.0.8.Final</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
</dependency>
<dependency>
<groupId>org.influxdb</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
@@ -10112,17 +10112,17 @@
<dependency>
<groupId>org.jetbrains.kotlin</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<artifactId>kotlin-script-util</artifactId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.10</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.21</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
</dependency>
<dependency>
<groupId>org.jetbrains.kotlin</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<artifactId>kotlin-scripting-jvm</artifactId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.10</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.21</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
</dependency>
<dependency>
<groupId>org.jetbrains.kotlin</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<artifactId>kotlin-scripting-jvm-host</artifactId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.10</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.21</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
</dependency>
<dependency>
<groupId>org.jruby.jcodings</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
@@ -10072,7 +10072,7 @@
<dependency>
<groupId>org.infinispan</groupId>
<artifactId>infinispan-jboss-marshalling</artifactId>
<version>13.0.6.Final</version>
<version>13.0.8.Final</version>
</dependency>
<dependency>
<groupId>org.influxdb</groupId>
@@ -10087,17 +10087,17 @@
<dependency>
<groupId>org.jetbrains.kotlin</groupId>
<artifactId>kotlin-script-util</artifactId>
<version>1.6.10</version>
<version>1.6.21</version>
</dependency>
<dependency>
<groupId>org.jetbrains.kotlin</groupId>
<artifactId>kotlin-scripting-jvm</artifactId>
<version>1.6.10</version>
<version>1.6.21</version>
</dependency>
<dependency>
<groupId>org.jetbrains.kotlin</groupId>
<artifactId>kotlin-scripting-jvm-host</artifactId>
<version>1.6.10</version>
<version>1.6.21</version>
</dependency>
<dependency>
<groupId>org.jruby.jcodings</groupId>
@@ -10072,7 +10072,7 @@
<dependency>
<groupId>org.infinispan</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<artifactId>infinispan-jboss-marshalling</artifactId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>13.0.6.Final</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>13.0.8.Final</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
</dependency>
<dependency>
<groupId>org.influxdb</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
@@ -10087,17 +10087,17 @@
<dependency>
<groupId>org.jetbrains.kotlin</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<artifactId>kotlin-script-util</artifactId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.10</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.21</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
</dependency>
<dependency>
<groupId>org.jetbrains.kotlin</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<artifactId>kotlin-scripting-jvm</artifactId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.10</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.21</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
</dependency>
<dependency>
<groupId>org.jetbrains.kotlin</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<artifactId>kotlin-scripting-jvm-host</artifactId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.10</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
<version>1.6.21</version><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->
</dependency>
<dependency>
<groupId>org.jruby.jcodings</groupId><!-- org.apache.camel.quarkus:camel-quarkus-bom:${project.version} -->

0 comments on commit 2eb971e

Please sign in to comment.