Skip to content
Permalink
Browse files
Merge pull request #1305 from ppalaga/200604-unrevert-java-8
Revert #1299 require Java 11
  • Loading branch information
oscerd committed Jun 4, 2020
2 parents 7abe84e + 7c1b0dd commit 3f7174194cf4bc041908273d8d73d117a2d03e68
Show file tree
Hide file tree
Showing 4 changed files with 4 additions and 7 deletions.
@@ -115,7 +115,7 @@ jobs:
strategy:
fail-fast: false
matrix:
java: [ '14' ]
java: [ '8' , '14' ]
env:
MAVEN_OPTS: -Xmx3000m
steps:
@@ -219,7 +219,7 @@ jobs:
# - name: Set Up Java
# uses: actions/setup-java@v1
# with:
# java-version: 11
# java-version: 1.8
# - name: Download Maven Repo
# uses: actions/download-artifact@v1
# with:
@@ -11,7 +11,7 @@
documentation.
* If your are on Linux, `docker` is sufficient for the native mode too. Use `-Pnative,docker` instead of `-Pnative`
if you choose this option.
* Java 11
* JDK 8+
* Maven 3.6.2+ (unless you use the Maven Wrapper, a.k.a. `mvnw` available in the source tree).

[[how-to-build]]
@@ -8,7 +8,7 @@ as a base for your real world project.

* A `git` client
* An IDE
* JDK 11+ with JAVA_HOME configured appropriately
* JDK 8+ with JAVA_HOME configured appropriately
* Apache Maven 3.6.2+
* GraalVM with `native-image` command installed and `GRAALVM_HOME` environment variable set, see
https://quarkus.io/guides/building-native-image-guide[Building a native executable] section of the Quarkus
@@ -487,9 +487,6 @@
<version>3.6.2</version>
</requireMavenVersion>
<rules>
<requireJavaVersion>
<version>11</version>
</requireJavaVersion>
<dependencyConvergence />
<requireMavenVersion>
<version>${supported-maven-versions}</version>

0 comments on commit 3f71741

Please sign in to comment.