Skip to content

Fix for CAMEL-6513 and CAMEL-6937 #56

Merged
merged 4 commits into from Sep 7, 2014

3 participants

@antoinesd

Makes weld 2.1.0 work and stop usage of beanprovider in extension to avoid error caused by bad bean resolution

@Tcharl Tcharl commented on the diff Mar 8, 2014
components/camel-cdi/pom.xml
@@ -43,12 +44,22 @@
org.apache.camel.cdi.component.*;${camel.osgi.version}
</camel.osgi.export.pkg>
<camel.osgi.provide.capability>
- org.ops4j.pax.cdi.extension; extension=camel-cdi-extension
+ org.ops4j.pax.cdi.extension; extension=camel-cdi-extension
@Tcharl
Tcharl added a note Mar 8, 2014

Hi,
I can be wrong but it looks like you've forgot the require-capability too: Require-Capability: osgi.extender;filter:="(osgi.extender=pax.cdi)",org.ops4j.pax.cdi.extension;filter:="(extension=pax-cdi-extension)", org.ops4j.pax.cdi.extension;filter:="(extension=deltaspike-core-api)"

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
@asfgit asfgit merged commit 0a241dd into apache:master Sep 7, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.