Skip to content
Permalink
Browse files
COMPRESS-604: Ensure compatibility with Java 8 (#252)
* COMPRESS-604: ensure compatibility with Java 8

Switch --release from 9 to 8 when building with JDK 9+

* COMPRESS-604: remove outdated warning for JDK 14+
  • Loading branch information
andrebrait committed Mar 11, 2022
1 parent 741374b commit c360b5a21687526b69c0df876e18004f9721d1d9
Show file tree
Hide file tree
Showing 2 changed files with 1 addition and 4 deletions.
@@ -49,9 +49,6 @@ Apache Commons Compress
[![Javadocs](https://javadoc.io/badge/org.apache.commons/commons-compress/1.21.svg)](https://javadoc.io/doc/org.apache.commons/commons-compress/1.21)
[![Fuzzing Status](https://oss-fuzz-build-logs.storage.googleapis.com/badges/apache-commons.svg)](https://bugs.chromium.org/p/oss-fuzz/issues/list?sort=-opened&can=1&q=proj:apache-commons)

**Note: Commons Compress currently doesn't build on JDK 14+, we will
address this before releasing Compress 1.21**.

Apache Commons Compress software defines an API for working with
compression and archive formats. These include: bzip2, gzip, pack200,
lzma, xz, Snappy, traditional Unix Compress, DEFLATE, DEFLATE64, LZ4,
@@ -621,7 +621,7 @@ Brotli, Zstandard and ar, cpio, jar, tar, zip, dump, 7z, arj.
<jdk>[9,)</jdk>
</activation>
<properties>
<maven.compiler.release>9</maven.compiler.release>
<maven.compiler.release>8</maven.compiler.release>
<animal.sniffer.skip>true</animal.sniffer.skip>
<!-- coverall version 4.3.0 does not work with java 9, see https://github.com/trautonen/coveralls-maven-plugin/issues/112 -->
<coveralls.skip>true</coveralls.skip>

0 comments on commit c360b5a

Please sign in to comment.