Skip to content
Permalink
Browse files
fix(GH-1391): Reword minimum build tools version to make it more clea…
…r what is actually required. (#1401)
  • Loading branch information
breautek committed Feb 22, 2022
1 parent f100809 commit 6d3ce211dd813cc39517a4173068168f7fe2b95e
Showing 1 changed file with 4 additions and 4 deletions.
@@ -64,16 +64,16 @@ String doFindLatestInstalledBuildTools(String minBuildToolsVersionString) {

if (highestBuildToolsVersion == null) {
throw new RuntimeException("""
No installed build tools found. Install the Android build tools
version ${minBuildToolsVersionString} or higher.
No installed build tools found. Please install the Android build tools
version ${minBuildToolsVersionString}.
""".replaceAll(/\s+/, ' ').trim())
}

if (highestBuildToolsVersion.isLowerThan(minBuildToolsVersionString)) {
throw new RuntimeException("""
No usable Android build tools found. Highest ${minBuildToolsVersion.getMajor()}.x installed version is
${highestBuildToolsVersion.getOriginalString()}; minimum version
required is ${minBuildToolsVersionString}.
${highestBuildToolsVersion.getOriginalString()}; Recommended version
is ${minBuildToolsVersionString}.
""".replaceAll(/\s+/, ' ').trim())
}

0 comments on commit 6d3ce21

Please sign in to comment.