Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
Browse files
Deprecation notice
  • Loading branch information
macdonst committed Aug 16, 2017
1 parent 7c6449e commit 15a342779ea6905d93332068eebdd357a3e538f3
Showing 3 changed files with 45 additions and 52 deletions.
@@ -24,6 +24,10 @@ cordova-plugin-compat

This repo is for remaining backwards compatible with previous versions of Cordova.

## Deprecated

> This plugin is no longer being worked on as the functionality provided by this plugin is now included in cordova-android 6.3.0. You should upgrade your application to use version 1.2.0 of this plugin. It will detect whether or not the plugin is required based on the version of cordova-android your app uses.
## USAGE

Your plugin can depend on this plugin and use it to handle the new run time permissions Android 6.0.0 (cordova-android 5.0.0) introduced.
@@ -1,37 +1,31 @@
{
"name": "cordova-plugin-compat",
"description": "This repo is for remaining backwards compatible with previous versions of Cordova.",
"version": "1.2.0-dev",
"homepage": "http://github.com/apache/cordova-plugin-compat#readme",
"repository": {
"type": "git",
"url": "git://github.com/apache/cordova-plugin-compat.git"
},
"bugs": {
"url": "https://github.com/apache/cordova-plugin-compat/issues"
},
"cordova": {
"id": "cordova-plugin-compat",
"platforms": [
"android"
]
},
"keywords": [
"ecosystem:cordova",
"ecosystem:phonegap",
"cordova-android"
],
"engines": {
"cordovaDependencies": {
"<1.2.0": {
"cordova": ">=5.0.0"
},
">=1.2.0": {
"cordova": ">=5.0.0",
"cordova-android": "<6.3.0"
}
}
},
"author": "Apache Software Foundation",
"license": "Apache-2.0"
"name": "cordova-plugin-compat",
"description": "[DEPRECATED] This repo is for remaining backwards compatible with previous versions of Cordova.",
"version": "1.2.0-dev",
"homepage": "http://github.com/apache/cordova-plugin-compat#readme",
"repository": {
"type": "git",
"url": "git://github.com/apache/cordova-plugin-compat.git"
},
"bugs": {
"url": "https://github.com/apache/cordova-plugin-compat/issues"
},
"cordova": {
"id": "cordova-plugin-compat",
"platforms": ["android"]
},
"keywords": ["ecosystem:cordova", "ecosystem:phonegap", "cordova-android"],
"engines": {
"cordovaDependencies": {
"<1.2.0": {
"cordova": ">=5.0.0"
},
">=1.2.0": {
"cordova": ">=5.0.0",
"cordova-android": "<6.3.0"
}
}
},
"author": "Apache Software Foundation",
"license": "Apache-2.0"
}
@@ -1,5 +1,4 @@
<?xml version="1.0" encoding="UTF-8"?>

<!--
Licensed to the Apache Software Foundation (ASF) under one
or more contributor license agreements. See the NOTICE file
@@ -18,25 +17,21 @@
specific language governing permissions and limitations
under the License.
-->

<plugin xmlns="http://cordova.apache.org/ns/plugins/1.0"
id="cordova-plugin-compat"
version="1.2.0-dev">
<name>Compat</name>
<description>Cordova Compatibility Plugin</description>
<license>Apache 2.0</license>
<keywords>cordova,compat</keywords>
<repo>https://git-wip-us.apache.org/repos/asf/cordova-plugin-compat.git</repo>

<engines>
<engine name="cordova" version=">=5.0.0"/>
<engine name="cordova-android" version="<6.3.0"/>
<plugin
xmlns="http://cordova.apache.org/ns/plugins/1.0" id="cordova-plugin-compat" version="1.2.0-dev">
<name>Compat</name>
<description>[DEPRECATED] Cordova Compatibility Plugin</description>
<license>Apache 2.0</license>
<keywords>cordova,compat</keywords>
<repo>https://git-wip-us.apache.org/repos/asf/cordova-plugin-compat.git</repo>
<engines>
<engine name="cordova" version=">=5.0.0"/>
<engine name="cordova-android" version="
<6.3.0"/>
</engines>

<!-- android -->
<platform name="android">
<source-file src="src/android/PermissionHelper.java" target-dir="src/org/apache/cordova" />
<source-file src="src/android/BuildHelper.java" target-dir="src/org/apache/cordova" />
</platform>

</plugin>
</plugin>

0 comments on commit 15a3427

Please sign in to comment.